Bug 832920 - Fix word-wrap in web front-end
Fix word-wrap in web front-end
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailman (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 04:05 EDT by Kamil Páral
Modified: 2012-11-20 08:43 EST (History)
2 users (show)

See Also:
Fixed In Version: mailman-2.1.12-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: There was no way how to wrap email with long-lines in web archive. Consequence: Long lines in web-archive were unwrapped. Fix: "white-space: pre-wrap;" CSS style has been added to all templates. Result: Long lines are wrapped now in browsers which support mentioned CSS style.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 08:43:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-06-18 04:05:46 EDT
Description of problem:
Mailman 2.1.12 does not wrap words in the web front-end. See:
http://lists.fedoraproject.org/pipermail/test/2012-June/108538.html
That is very inconvenient when using it to read the emails.

Mailman 2.1.13 wraps words. See:
https://lists.ubuntu.com/archives/ubuntu-qa/2012-June/002170.html

The relevant patch is:
> revno: 1210
> committer: Mark Sapiro <mark@msapiro.net>
> branch nick: 2.1
> timestamp: Mon 2009-12-14 14:41:45 -0800
> message:
>    - Updated docs for 2.1.13 release.
>   
>    - Added "white-space: pre-wrap" style for <pre> tag in archives.
>      Bug #266467.

Please update mailman or backport the patch.

Version-Release number of selected component (if applicable):
Mailman 2.1.12
Comment 7 Jan Kaluža 2012-07-31 06:52:05 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: There was no way how to wrap email with long-lines in web archive.

Consequence: Long lines in web-archive were unwrapped.

Fix: "white-space: pre-wrap;" CSS style has been added to all templates.

Result: Long lines are wrapped now in browsers which support mentioned CSS style.
Comment 11 errata-xmlrpc 2012-11-20 08:43:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1474.html

Note You need to log in before you can comment on or make changes to this bug.