Bug 832936 - gnome-control-center sound crashed in remove_on_complete
gnome-control-center sound crashed in remove_on_complete
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 04:43 EDT by Zdenek Kabelac
Modified: 2013-03-15 08:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 08:07:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bt full (5.00 KB, text/plain)
2012-06-18 04:43 EDT, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2012-06-18 04:43:23 EDT
Created attachment 592564 [details]
bt full

Description of problem:

I've noticed this coredump on my T61:

#0  remove_on_complete (timeline=0x1985bc0 [ClutterPropertyTransition], data=0x1937fe0) at cc-notebook.c:469
#1  0x00007fa3934dab33 in _g_closure_invoke_va (closure=closure@entry=0x2d75cf0, return_value=return_value@entry=0x0, 
    instance=instance@entry=0x1985bc0, args=args@entry=0x7ffff047f958, n_params=0, param_types=0x0) at gclosure.c:840
#2  0x00007fa3934f4315 in g_signal_emit_valist (instance=0x1985bc0, signal_id=<optimized out>, detail=0, 
    var_args=var_args@entry=0x7ffff047f958) at gsignal.c:3207
#3  0x00007fa3934f49c2 in g_signal_emit (instance=instance@entry=0x1985bc0, signal_id=<optimized out>, detail=detail@entry=0)
    at gsignal.c:3352
#4  0x00007fa394872714 in clutter_timeline_do_frame (timeline=0x1985bc0 [ClutterPropertyTransition])
    at ./clutter-timeline.c:1040
#5  0x00007fa39483ea18 in master_clock_advance_timelines (master_clock=0x161b190 [ClutterMasterClock])
    at ./clutter-master-clock.c:344
#6  clutter_clock_dispatch (source=source@entry=0x1622c00, callback=<optimized out>, user_data=<optimized out>)
    at ./clutter-master-clock.c:516
#7  0x00007fa3931f27b5 in g_main_dispatch (context=0x79a250) at gmain.c:2539
#8  g_main_context_dispatch (context=context@entry=0x79a250) at gmain.c:3075
#9  0x00007fa3931f2ae8 in g_main_context_iterate (context=context@entry=0x79a250, block=block@entry=1, dispatch=dispatch@entry=
    1, self=<optimized out>) at gmain.c:3146
#10 0x00007fa3931f2ba4 in g_main_context_iteration (context=0x79a250, context@entry=0x0, may_block=may_block@entry=1)
    at gmain.c:3207
#11 0x00007fa393f319fc in g_application_run (application=0x1735170 [GtkApplication], argc=argc@entry=2, argv=argv@entry=
    0x7ffff047fd28) at gapplication.c:1607
#12 0x00000000004095d2 in main (argc=2, argv=0x7ffff047fd28) at control-center.c:256

(gdb)  print *data
$3 = {notebook = 0x6f2d676f6c616e61, frame = 0x70732d7475707475}


this looks like complete bogus data.




Version-Release number of selected component (if applicable):
control-center-3.5.2-1.fc18.x86_64

How reproducible:


Steps to Reproduce:
1. no idea
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bastien Nocera 2013-03-15 08:07:51 EDT
We don't use the custom clutter based notebook anymore (and it was removed before 3.6 was out).

Note You need to log in before you can comment on or make changes to this bug.