Bug 832972 - [engine][setupNetworks] Sync network configuration on failure too
[engine][setupNetworks] Sync network configuration on failure too
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mike Kolesnik
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 05:52 EDT by Mike Kolesnik
Modified: 2016-02-10 14:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 08:23:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Kolesnik 2012-06-18 05:52:30 EDT
Description of problem:
If setup networks fails, the network configuration will not be synced from the host but it might be different there than what the engine knows.
Therefore, if the setup networks fails on the host, the engine should sync the configuration (getVdsCaps) to what the host knows.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Call setup networks and attach a network (non VLAN) to ethX
2. Delete the network_name from ethX in the vds_interfaces table
3. Call setup networks again an attach a different network (non VLAN) to ethX

  
Actual results:
VDSM should fail because a network is already attached to ethX, but this will not be seen on the interface in the UI/REST.


Expected results:
The already attached network should appear on the interface, even though setup networks had failed.


Additional info:
Also it's possible not to sync at the end, but instead mark network config as "unknown" so that the user has indication that the engine is out-of-sync, and try to remedy the situation (either automatically or manually).
Comment 2 Mike Kolesnik 2012-07-22 04:36:09 EDT
You can reproduce this, instead of altering in the DB, like this:
1. Create bridge on the host with any name you want (In the network-scripts folder) and assign it to ethX.
2. Make sure you DON'T bring the host up.
3. Call setup networks, and try to attach a (non VLAN) network to ethX.
Comment 3 lpeer 2012-08-14 08:23:27 EDT
refreshing the network configuration from the host in case of a failure is problematic as it is a blocking command and the UI is stuck.

This should be fix as part of enabling manual refresh capabilities or refresh network configuration

Note You need to log in before you can comment on or make changes to this bug.