Bug 833005 - Should mention required free space on the disk
Should mention required free space on the disk
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: fedora-websites (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 07:35 EDT by techtonik
Modified: 2015-03-04 16:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-04 16:36:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description techtonik 2012-06-18 07:35:49 EDT
It is not clear if 20Gb partition should be enough for installing F17 or not. There is a suspiction that installer just can't parse partition table correctly, but it is hard to guess without given data.
Comment 1 Luis Bazan 2012-06-28 15:15:23 EDT
Requirements

http://docs.fedoraproject.org/en-US/Fedora/17/html/Installation_Quick_Start_Guide/Requirements.html

The computer on which you intend to install Fedora 17 from the live CD should have:

    a CD or DVD drive, and the capability to boot from this drive.
    a 400 MHz processor or faster
    at least 1 GB of memory (RAM)
    at least 10 GB of permanent storage (hard drive) space. 

please Tell me more about this topic.
Comment 2 techtonik 2012-06-28 17:21:27 EDT
There aren't any links to this info from the download page, and I was not using live CD, but tried preupgrade and when it failed - reinstalled from scratch from USB.
Comment 3 Pete Travis 2012-07-11 01:25:03 EDT
The pertinent section of the Installation Guide actually refers the reader to the Release notes for the figures, although I do think the information would be a useful inclusion.

The website does offer a "Getting Help" link on the post-download page, which includes a link to https://docs.fedoraproject.org . It doesn't link directly to the minimum system requirements, or to any other specific bit of information. That said, website concerns would be best addressed in a bug against fedora-websites, or the website team's list at https://lists.fedoraproject.org/mailman/listinfo/websites
Comment 4 Luis Bazan 2012-07-31 15:57:46 EDT
We can close this ticket, taking into consideration the comment 3 and redirecting this issue to fedora-websites

Regards!
Comment 5 techtonik 2012-07-31 17:44:54 EDT
Do as you wish. I've already made my point that this information is hard to find.
Comment 6 Jack Reed 2012-11-05 01:00:48 EST
No separate bug appears to have been filed for this issue against the fedora-websites component, so I am transferring this bug to that component so the website team can evaluate whether stating the space requirements more clearly on the 'Download Fedora' page is necessary.

I notice that the sidebar at http://fedoraproject.org/get-fedora pertains to the live image, given that that ISO is featured on this page and is linked to in the 'What Do I Do?' procedure.

At http://fedoraproject.org/en/get-fedora-options#formats, where the full DVD ISO links are found (the reporter was not using a live image), space requirements are not explained. 

This may be contributing to the reporter's uncertainty. He may wish to clarify this now that this bug is with the website team.
Comment 7 Elad Alfassa 2012-11-05 01:08:04 EST
On the main https://fedoraproject.org/ page (and in https://fedoraproject.org/en/get-fedora), we have a "Recommended installation requirements" list on the sidebar, which contains

10GB disk space / storage

I guess this bug report is asking us to add it to the https://fedoraproject.org/en/get-fedora-options#formats page, am I correct?
Comment 8 Jack Reed 2012-11-05 01:26:07 EST
I hadn't noticed that on the front page, which would indeed imply that it applies to all installations, live image or otherwise. But yes, that's the sidebar I was referring to on the Get Fedora page.

And yes, that's what I infer would best address the reporter's concern, but they may have a different take. Based on Comment 5 there may be no further input from them though, so I transferred this really so you guys could determine the best way to get that information across unambiguously and consistently across the relevant areas of the website. If you decide that no action is required, no problem. If the difference between the size of a live and DVD installation is negligible, the current information will likely suffice.
Comment 9 techtonik 2012-11-05 02:20:59 EST
Having 'requirements' with exact space amount on front and download page probably solves my original user story, although I may be looking for more detailed explanation. The reason I was looking for info was that I already had 10Gb space partition (if I remember correctly) when Anaconda failed and left my system broken (bug #832951). I don't remember if there was 10Gb of free space on this partition, but that's another story related to preupgrade, which didn't make proper checks.

Lack of OpenID/OpenAuth (Google) support make is hard to give more feedback, so after comment 5 I was negligent to search for password. Please also think how to improve this. I kicked myself to recover password mostly because bug #832951 about screwed up F16->F17 preupgrade is not addressed yet 2 days before F18 release.
Comment 10 Robert Mayr 2015-03-04 16:36:23 EST
Closing this ticket because we don't have https://fedoraproject.org anymore, but are on https://getfedora.org since F21.
For system requirements users are invited to read the Installation Guide, as clearly stated in the download page, for example here:
https://getfedora.org/en/workstation/download/

Note You need to log in before you can comment on or make changes to this bug.