Bug 833054 - No more SAVEDIR in dhclient-script
No more SAVEDIR in dhclient-script
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 09:45 EDT by derrien
Modified: 2012-06-27 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:45:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description derrien 2012-06-18 09:45:18 EDT
Description of problem:

There is no more SAVEDIR in dhclient-script so SERVERFILE=$SAVEDIR/chrony.servers.$interface in /etc/dhcp/dhclient.d/chrony.sh creates file in / (not very clean...) and /usr/libexec/chrony-helper add-dhclient-servers doesn't work if you use network legacy

Version-Release number of selected component (if applicable):
dhclient-4.2.4-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jiri Popelka 2012-06-18 10:27:04 EDT
Thanks for the investigation.

Yes, I removed the SAVEDIR variable in
http://pkgs.fedoraproject.org/gitweb/?p=dhcp.git;a=commitdiff;h=1e3f54a9ec3e1610b8ad4920c6c6b0c4c80a1e22
because it's not used in dhclient-script anymore.

I see that /etc/dhcp/dhclient.d/nis.sh uses it too so I've just put it back.
Comment 2 Fedora Update System 2012-06-18 10:36:03 EDT
dhcp-4.2.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-2.fc17
Comment 3 Fedora Update System 2012-06-19 11:04:41 EDT
Package dhcp-4.2.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.4-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9603/dhcp-4.2.4-2.fc17
then log in and leave karma (feedback).
Comment 4 derrien 2012-06-20 07:19:05 EDT
I updated dhclient only. It's OK.
Comment 5 Fedora Update System 2012-06-27 23:45:03 EDT
dhcp-4.2.4-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.