Bug 833058 - /etc/lsb-release does not exist
/etc/lsb-release does not exist
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
6.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Ondrej Vasik
Miroslav Hradílek
:
Depends On:
Blocks: 881827
  Show dependency treegraph
 
Reported: 2012-06-18 09:48 EDT by Dan Bryant
Modified: 2013-02-21 05:46 EST (History)
1 user (show)

See Also:
Fixed In Version: redhat-lsb-4.0-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:46:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Bryant 2012-06-18 09:48:22 EDT
Description of problem:
/etc/lsb-release does not exist, even though (to quote the man page of lsb_release) "If the installation is LSB compliant, the "/etc/lsb-release" file should contain the LSB_VERSION field. The value of the field should be a colon separated list of supported module versions indicating the LSB specification modules to which the installation is compliant. If the installation is not compliant, the above field should not be present."

As this file does not exist we are led to believe RHEL6.2 is not LSB-compliant.

Version-Release number of selected component (if applicable):
redhat-lsb-4.0-3

How reproducible:
Every time.

Steps to Reproduce:
1. cat /etc/lsb-release 
2. lsb_release -a
  
Actual results:
/etc/lsb-release doesn't exist.
lsb_release -a displays the correct LSB information.

Expected results:
/etc/lsb-release at least contains "LSB_VERSION=core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch"

Additional info:
Correct information can be created: 
echo "LSB_VERSION=`lsb_release -v | awk '/Version/ {print substr($3,2)}'`" > /etc/lsb-release
Ideally all the information that is in the /etc/redhat-release file should be in the /etc/lsb-release file.
Comment 3 Ondrej Vasik 2012-11-22 04:23:44 EST
Thanks for the suggestion, you are right, we should provide it. However - it is not completely easy - as you have to make sure there is always correct information in the /etc/lsb-release file when you install/uninstall e.g. redhat-lsb-graphics. However, doable, though more invasive than oneline.

It is not necessary to have all the information there - just LSB_VERSION is enough - other fields are optional and are in /etc/redhat-release.
Comment 8 errata-xmlrpc 2013-02-21 05:46:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0448.html

Note You need to log in before you can comment on or make changes to this bug.