Bug 833074 - Firefox SSL seems to be broken with gmail.com
Firefox SSL seems to be broken with gmail.com
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 10:18 EDT by Trever Adams
Modified: 2012-07-24 08:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 06:18:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of failure (346.56 KB, image/png)
2012-06-21 11:02 EDT, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2012-06-18 10:18:44 EDT
Description of problem:
Firefox 13 displays a bunch of garbage on gmail.com in Linux. This appears to be a failure of SSL/TLS as the login page is just garbage.

Version-Release number of selected component (if applicable):
firefox-13.0-1.fc17.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Use Firefox 12 
2. Go to gmail.com
3. Everything works
4. Upgrade and try again
5. Everything breaks
 

This does not appear to affect other SSL/TLS websites (I don't use many).
Comment 1 Martin Stransky 2012-06-21 10:01:19 EDT
Can you paste screenshot of the garbage/webpage? I can't reproduce it on my box.
Comment 2 Trever Adams 2012-06-21 11:02:08 EDT
Created attachment 593475 [details]
Screenshot of failure

Is there a way to temporarily disable all addons to see if they are the problem?

I use community ubiquity, firebug, and beeftaco (on some systems) and link status redux.
Comment 3 Martin Stransky 2012-06-21 11:04:07 EDT
Yes, run Firefox in safe mode, by "firefox -safe-mode" on terminal.
Comment 4 Trever Adams 2012-06-21 11:07:23 EDT
Alright, I have tried with all plguins disabled. It doesn't work. I have tried in epiphany, it works there so it isn't some weird DNS hijack.
Comment 5 Trever Adams 2012-06-21 11:08:38 EDT
I have blown away my profile cert8.db just in case I had some bad certs. This didn't fix anything.
Comment 6 Trever Adams 2012-06-25 02:46:51 EDT
I am very sorry. My profile became corrupted somehow in the upgrade. The following key in the settings was zeroed "network.http.accept-encoding". Of course it should contain "gzip,defalte".

I am not sure how this should be closed as it is a bug that the settings became screwed up. Was it unique to my setup? Maybe.
Comment 7 Martin Stransky 2012-06-26 06:18:32 EDT
Thanks for the info.
Comment 8 Trever Adams 2012-07-20 12:04:12 EDT
Ok, There is something seriously wrong going on with Firefox packaging. My accept-encoding in settings just went empty again with the Firefox 14 package!
Comment 9 Martin Stransky 2012-07-23 04:46:29 EDT
Can you try to create a new empty profile? Was the preference lost by update from ff 13 to ff 14? Can you reproduce it (if you downgrade to firefox 13, set up the preference and update firefox to ff 14).
Comment 10 Trever Adams 2012-07-24 08:00:03 EDT
I was unable to reproduce with empty profile. Yes, FF12 to 13 and 13 to 14. I do not know if this is relevant or not, but I use my own weave server with sync. It also seems to only happen once per upgrade (I have a Windows Domain account and several Linux accounts on different machines synced with this weave server and it only happens on the first machine to start the upgraded FF. If I fix it there, it doesn't show up elsewhere.)

I will have to try the downgrade/upgrade later.

Note You need to log in before you can comment on or make changes to this bug.