Bug 833078 - Root volume support for LVM mirroring
Root volume support for LVM mirroring
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut (Show other bugs)
6.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jonathan Earl Brassow
Release Test Team
:
: 816184 (view as bug list)
Depends On:
Blocks: 498670 760559 958503 960739
  Show dependency treegraph
 
Reported: 2012-06-18 10:27 EDT by Jonathan Earl Brassow
Modified: 2013-12-10 16:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 00:32:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2012-06-18 10:27:25 EDT
After failure to activate the root logical volume, dracut should be able to check if the LV is mirrored or RAID and proceed.

This should involve a small amount of checking code (to determine segment type) and code that repairs and/or activates the volume in partial mode.
Comment 1 Alexander Todorov 2012-08-06 03:47:59 EDT
Jonathan,
can you be more verbose? Can you describe steps to reproduce a particular problem ?
Comment 2 Jonathan Earl Brassow 2012-09-21 15:22:36 EDT
to recreate the problem, make your root volume either a RAID or 'mirror' logical volume, reboot the machine with a missing device.  The machine will not boot.

you can convert an existing linear root volume to RAID or 'mirror' by doing the following:
~> lvconvert --type raid1 -m 1 <VG>/<LV>
or
~> lvconvert -m 1 <VG>/<LV>
Comment 3 Jonathan Earl Brassow 2012-10-15 18:03:12 EDT
Note that the RAID logical volumes already work as root volumes.  'mirror' segment type does not.  If users want to mirror their root volume, they should use the LVM 'raid1' segment type for now.

This bug is low priority for 6.4 because only the 'mirror' segment type does not work and the 'raid1' segment type provides a preferred alternative.
Comment 5 Harald Hoyer 2013-02-11 07:40:46 EST
dracut >= 004-231 should support assembling lvm mirrors with "--partial"
Comment 7 Jonathan Earl Brassow 2013-05-29 13:41:53 EDT
I don't think you mean to devel ACK this do you?

See comment 3.  It is insufficient to try to activate with '--partial' flag for "mirror" segment type.  Users can use the "raid1" segment type.  It is the preferred RAID1 implementation, it does respond to the '--partial' flag, and is already available.

Let's not support the "mirror" segment type for the root volume.  What I don't know is where the best place to document this is - that "raid1" is allowed, but "mirror" is not for the root volume.
Comment 8 RHEL Product and Program Management 2013-05-30 00:32:36 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 12 Jonathan Earl Brassow 2013-12-10 16:53:48 EST
*** Bug 816184 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.