Bug 833101 - webadmin: there is no information presented on a direct lun once we create it
webadmin: there is no information presented on a direct lun once we create it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
vvyazmin@redhat.com
storage
: Reopened
: 819297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 11:06 EDT by Dafna Ron
Modified: 2016-02-10 11:56 EST (History)
10 users (show)

See Also:
Fixed In Version: SI15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shots (121.03 KB, application/x-gzip)
2012-06-18 11:06 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-18 11:06:01 EDT
Created attachment 592685 [details]
screen shots

Description of problem:

when we create a direct lun the disk is shown with N/A on the following fields: Storage domain, Allocation, Status, Creation date. 

when we press the edit tab we also do not see no information on the lun 

and we also do not have any information on the lun in the disks main tab

as a result, if I add a large number of direct luns (lets say I work only with direct luns and I have 200 vm's) I have no way of knowing what lun I added to each vm. 

Version-Release number of selected component (if applicable):

si6

How reproducible:

100%

Steps to Reproduce:
1. create a direct lun
2. look at the lun under the disks sub tab (in vm's) 
3. press the edit button 
4. look at the disk in main disks tab
  
Actual results:

there is no information on the lun

Expected results:

we should have information on the lun. 

Additional info: screen shots
Comment 1 Tal Nisan 2012-06-25 10:37:21 EDT
The fields are not applicable, that's why they appear as N/A:

Storage domain - The luns are external and not a part of a storage domain

Allocation - There is no allocation type as preallocated/thin provision, those are actual disks

Status - No status is available, we are not managing the disks

Creation date - This info is not relevant for lun disks
Comment 2 Dafna Ron 2012-06-25 11:23:00 EDT
of course they are not. 
but edit disk should be showing information which they are not
reopening bug since we need to show some info for direct luns
Comment 3 Tal Nisan 2012-06-25 11:33:46 EDT
Which info should be shown there? All fields are irrelevant or not available...
Comment 4 Dafna Ron 2012-06-25 11:48:05 EDT
Tal, if I have a 100 vm's and I want to add a direct lun to each, once I did, how can I tell anything about the lun? how can I tell which lun I added to each vm, or any basic information on it for that matter? not having any info will make direct luns very hard to manage. 

please speak to Ayal and PM's and decide on the course of action for this, 
but this is most defiantly a bug.
Comment 5 Yaniv Kaul 2012-06-26 07:32:54 EDT
Setting needinfo on PM - I feel the design is a bit lacking here. I understand why there's no information currently for the direct lun disks they don't correspond to current displayed fields - but clearly there has to be.
Comment 6 Ayal Baron 2012-06-28 17:44:34 EDT
(In reply to comment #5)
> Setting needinfo on PM - I feel the design is a bit lacking here. I
> understand why there's no information currently for the direct lun disks
> they don't correspond to current displayed fields - but clearly there has to
> be.

There is no question about it.
Currently the biggest problem here is as you say that the displayed fields are totally irrelevant to a LUN.
In the sub tab we will display the LUN info, however, as long as we have the abstraction that both regular disks and LUNs are treated the same way we will not be able to show info in the main tab.
Comment 7 Andrew Cathrow 2012-08-08 11:32:28 EDT
Ayal, what options do we have to display at least the wwid?
Comment 11 vvyazmin@redhat.com 2012-08-23 09:41:41 EDT
Verified on RHEVM 3.1 - SI15

RHEVM: rhevm-3.1.0-13.el6ev.noarch
VDSM: vdsm-4.9.6-29.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.298.el6_3.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64
Comment 12 Daniel Erez 2012-09-24 14:01:08 EDT
*** Bug 819297 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.