Bug 833142 - rpc.svcgssd leaks memory
rpc.svcgssd leaks memory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 13:20 EDT by Lukas Hejtmanek
Modified: 2012-10-08 09:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 09:09:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Hejtmanek 2012-06-18 13:20:46 EDT
Description of problem:
If I run rpc.svcgssd for a longer time (couple of days), it uses 1.4GB of RAM (RSS) (running for 45 hours).

Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-15.el6_2.1.x86_64

How reproducible:
Set SECURE_NFS=yes. I do not use -n switch.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Huge mem leaks.

Expected results:
Stable RSS usage over time.

Additional info:
Got RHEL pre-paid support, don't know whether it is relevant here.
Comment 3 Lukas Hejtmanek 2012-07-28 09:03:45 EDT
Seems to be fixed in RHEL 6.3

Note You need to log in before you can comment on or make changes to this bug.