Bug 833180 - linear to striped raid conversion 'not supported' message doesn't make sense
linear to striped raid conversion 'not supported' message doesn't make sense
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 15:35 EDT by Corey Marthaler
Modified: 2013-02-21 03:10 EST (History)
9 users (show)

See Also:
Fixed In Version: lvm2-2.02.98-1.el6
Doc Type: Bug Fix
Doc Text:
When attempting to convert a linear logical volume to a RAID 4/5/6 logical volume, a confusing message would result. This operation is not allowed, but the message would indicate the original logical volume was "striped" instead of "linear". This has been corrected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:10:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-06-18 15:35:11 EDT
Description of problem:
One sees this message when attempting to go from linear -> raid[4|5|6].


[root@hayes-01 bin]# lvs -a -o +devices
  LV         VG          Attr     LSize    Devices
  fs_to_raid raid_sanity -wi-a--- 300.00m  /dev/etherd/e1.1p9(0)

[root@hayes-01 bin]# lvconvert --type raid4 -i 2 /dev/raid_sanity/fs_to_raid
  Converting the segment type for raid_sanity/fs_to_raid from striped to raid4 is not yet supported.


"from striped to raid4" shouldn't it be "from linear to raid4" since it's not yet striped.



Version-Release number of selected component (if applicable):
2.6.32-278.el6.x86_64
lvm2-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-libs-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-cluster-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
cmirror-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
Comment 1 Alasdair Kergon 2012-06-18 15:42:44 EDT
Should be using
  seg->segtype->ops->name(seg)
instead of accessing
  seg->segtype->name
directly.

(Audit the rest of the code base for the same error too.)
Comment 2 Jonathan Earl Brassow 2012-09-05 12:40:00 EDT
commit c3eb3a76875ccf8c544c991bc52b6b3061bf8f58
Author: Jonathan Brassow <jbrassow@redhat.com>
Date:   Wed Sep 5 11:35:54 2012 -0500

    cleanup:  Use segtype->ops->name() instead of segtype->name where applicable
    
    When printing a message for the user and the lv_segment pointer is available
    use segtype->ops->name() instead of segtype->name.  This gives a better
    user-readable name for the segment.  This is especially true for the
    'striped' segment type, which prints "linear" if there is an area_count of
    one.
Comment 3 Jonathan Earl Brassow 2012-09-05 12:41:02 EDT
Unit test:

[root@hayes-01 lvm2]# lvs --segments vg
  LV   VG   Attr     #Str Type   SSize  
  lv   vg   -wi-a---    1 linear 100.00m
[root@hayes-01 lvm2]# lvconvert --type raid4 -i 2 vg/lv
  Converting the segment type for vg/lv from linear to raid4 is not yet supported.
Comment 5 Corey Marthaler 2013-01-21 19:57:29 EST
Fix verified in the latest rpms.

2.6.32-354.el6.x86_64
lvm2-2.02.98-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
lvm2-libs-2.02.98-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
lvm2-cluster-2.02.98-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
udev-147-2.43.el6    BUILT: Thu Oct 11 05:59:38 CDT 2012
device-mapper-1.02.77-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
device-mapper-libs-1.02.77-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
device-mapper-event-1.02.77-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
device-mapper-event-libs-1.02.77-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013
cmirror-2.02.98-8.el6    BUILT: Wed Jan 16 07:57:25 CST 2013


[root@qalvm-01 ~]# lvconvert --type raid4 -i 3 /dev/raid_sanity/fs_to_raid
  Converting the segment type for raid_sanity/fs_to_raid from linear to raid4 is not yet supported.
[root@qalvm-01 ~]# lvconvert --type raid5 -i 3 /dev/raid_sanity/fs_to_raid
  Converting the segment type for raid_sanity/fs_to_raid from linear to raid5 is not yet supported.
[root@qalvm-01 ~]# lvconvert --type raid6 -i 3 /dev/raid_sanity/fs_to_raid
  Converting the segment type for raid_sanity/fs_to_raid from linear to raid6 is not yet supported.
[root@qalvm-01 ~]# lvconvert --type raid10 -i 3 /dev/raid_sanity/fs_to_raid
  Converting the segment type for raid_sanity/fs_to_raid from linear to raid10 is not yet supported.
Comment 6 errata-xmlrpc 2013-02-21 03:10:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html

Note You need to log in before you can comment on or make changes to this bug.