Bug 833201 - Failed to add host - does not accept vdsm 4.10
Failed to add host - does not accept vdsm 4.10
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.1 RC
Unspecified Linux
urgent Severity urgent
: ---
: 3.1
Assigned To: Dan Kenigsberg
Haim
: Reopened
Depends On:
Blocks: 822145 918109
  Show dependency treegraph
 
Reported: 2012-06-18 17:03 EDT by Trey Dockendorf
Modified: 2014-01-12 19:52 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 918109 (view as bug list)
Environment:
Last Closed: 2013-03-05 02:58:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trey Dockendorf 2012-06-18 17:03:32 EDT
Description of problem:

When adding a host through the web interface the bootstrap process fails on the node that the VDSM version is incorrect.


Version-Release number of selected component (if applicable):

ovirt-engine-3.1-beta
vdsm-4.10.0-0.33.git40b2d55


How reproducible:

Every time

Steps to Reproduce:
1. Install vdsm 4.10* to node
2. Attempt to add node via engine interface

  
Actual results:

Mon, 18 Jun 2012 14:20:20 DEBUG    **** Start VDS Validation ****
Mon, 18 Jun 2012 14:20:20 DEBUG    Entered VdsValidation(subject = 'dc-kvm0.tamu.edu', random_num = '8408ad00-510d-47a7-98e9-ed73d95ad85d', rev_num = 'None', installVirtualizationService = 'True', installGlusterService = 'False')
Mon, 18 Jun 2012 14:20:20 DEBUG    Setting up Package Sacks
Mon, 18 Jun 2012 14:20:22 DEBUG    yumSearch: found vdsm entries: [<YumAvailablePackageSqlite : vdsm-4.10.0-0.33.git40b2d55.el6.x86_64 (0x17e8e90)>]
Mon, 18 Jun 2012 14:20:22 DEBUG    Host properly registered with RHN/Satellite.
Mon, 18 Jun 2012 14:20:22 DEBUG    <BSTRAP component='RHN_REGISTRATION' status='OK' message='Host properly registered with RHN/Satellite.'/>
Mon, 18 Jun 2012 14:20:25 DEBUG    yumSearchVersion: pkg vdsm-4.10.0-0.33.git40b2d55.el6.x86_64 does not start with: vdsm-4.9
Mon, 18 Jun 2012 14:20:25 ERROR    Unable to fetch VDSM with minimal version of vdsm-4.9. Please check if host is properly registered with updated yum repository
Mon, 18 Jun 2012 14:20:25 DEBUG    <BSTRAP component='VDSM_MAJOR_VER' status='FAIL' message='Unable to fetch VDSM with minimal version of vdsm-4.9. Please check if host is properly registered with updated yum repository'/>
Mon, 18 Jun 2012 14:20:25 ERROR    checkMajorVersion test failed
Mon, 18 Jun 2012 14:20:25 DEBUG    <BSTRAP component='RHEV_INSTALL' status='FAIL'/>
Mon, 18 Jun 2012 14:20:25 DEBUG    **** End VDS Validation ****


Expected results:

Node is successfully added to oVirt

Additional info:
Comment 1 Trey Dockendorf 2012-06-18 17:17:34 EDT
Patch provided by by Dan Kenigsberg here , http://lists.ovirt.org/pipermail/users/2012-June/002468.html, solved the issue.  Host was successfully added after the patch to vds_bootstrap.py.
Comment 2 Itamar Heim 2012-06-19 00:05:51 EDT
why is this patch correct?
what if i want to install a vdsm-4.9 (3.0 compatibility level) on the host?
Comment 3 Dan Kenigsberg 2012-06-19 03:43:31 EDT
(In reply to comment #2)
> why is this patch correct?
> what if i want to install a vdsm-4.9 (3.0 compatibility level) on the host?

I really hate the patch (even though I think it is good enough for ovirt-3.1)

I've posted another patch which is slightly saner.

http://gerrit.ovirt.org/#/c/5469/
Comment 4 Federico Simoncelli 2012-06-22 07:54:22 EDT
In the ovirt-3.1 branch as: 67309fc8a7a4edd4996490b64f51ce37f0ed2327
Comment 5 Itamar Heim 2012-08-09 04:05:43 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/
Comment 6 Stefanie Forrester 2013-03-04 20:02:12 EST
Hi,

I was having this issue in RHEV 3.0, so today I upgraded to 3.1. The issue still appears to be present, since I'm unable to add any RHEL hosts through the RHEV Manager. 

I'm not getting the entire error listed above, but I am receiving this part:

"Unable to fetch VDSM with minimal version of vdsm-4.9."

The RHN-checks seem to return successfully, but it fails the next step:

Received message: <BSTRAP component='RHN_REGISTRATION' status='OK' message='Host properly registered with RHN/Satellite.'/>. FYI. (Stage: Running first installation script on Host)
2013-03-04 19:22:21,456 INFO  [org.ovirt.engine.core.bll.VdsInstaller] (NioProcessor-11) Installation of 10.16.67.136. Received message: <BSTRAP component='VDSM_MAJOR_VER' status='FAIL' message='Unable to fetch VDSM with minimal version of vdsm-4.9. Please check if host is properly registered with updated yum repository'/>. FYI. (Stage: Running first installation script on Host)
2013-03-04 19:22:21,656 ERROR [org.ovirt.engine.core.bll.VdsInstaller] (NioProcessor-11) Installation of 10.16.67.136. Received message: <BSTRAP component='RHEV_INSTALL' status='FAIL'/>. Error occured. (Stage: Running first installation script on Host)


The hypervisor has vdsm version 4.10.2-1.6.el6.x86_64 available in its repos. And the RHEV Manager has vdsm-bootstrap-4.9.6-45.2.el6_3.noarch installed. I am using some internal repositories, but I've been told they mirror RHN.

For RHEVM:
http://download.devel.redhat.com/sysrepos/rhel6-server-rhevm-3.1-x86_64/RPMS.rhevm_3.1/

For the hypervisor:
http://download.devel.redhat.com/sysrepos/rhel6-rhev-mgmt-agent-6-x86_64/RPMS.agent_6/

I tested adding a RHEVH host to this RHEV instance, and it worked. So it's only affecting the regular RHEL hosts, which are most likely still having issues with vdsm version compatibility.
Comment 7 Dan Kenigsberg 2013-03-05 02:58:37 EST
I believe that this issue was indeed solved by ovirt commit http://gerrit.ovirt.org/5544 . So keeping this bug closed is correct.

However, in order to get the fixed code into rhev-3.1.z, you would have to upgrade the vdsm-bootstrap.rpm that is installed on your rhev-m machine. Does this solve the issue?

If this does not help, please clone this bug to the RHEV-M-3.1 project.
Comment 8 Stefanie Forrester 2013-03-05 08:55:49 EST
Thanks for the quick response. There's a good chance that this patch solves the issue. I guess my problem is not having in it in RHEV 3.1. I'll go ahead and clone this bug for RHEVM.
Comment 9 Dan Kenigsberg 2013-03-05 11:04:00 EST
(In reply to comment #8)
> Thanks for the quick response. There's a good chance that this patch solves
> the issue. I guess my problem is not having in it in RHEV 3.1. I'll go ahead
> and clone this bug for RHEVM.

It *should* be on RHEV 3.1.z - please clone this bug only after you verify that vdsm-bootstrap-4.10.2-1.6 does not solve your problem.

Note You need to log in before you can comment on or make changes to this bug.