Bug 833208 - banshee does not include upnp support
banshee does not include upnp support
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ismael Olea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 17:29 EDT by javiermon
Modified: 2013-04-30 07:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-30 07:40:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description javiermon 2012-06-18 17:29:32 EDT
Description of problem:
Banshee 2.4 has support for UPNP but it's not included in fedora 18.

Version-Release number of selected component (if applicable):
Paquetes instalados
Nombre        : banshee
Arquitectura        : x86_64
Versión     : 2.4.1
Lanzamiento     : 1.fc17
Tamaño        : 13 M
Repositorio        : installed
Desde el repositorio   : updates


How reproducible:
always

Steps to Reproduce:
1. Start banshee
2. go to extensions
3. no upnp
  
Actual results:


Expected results:


Additional info:
Comment 1 javiermon 2012-10-23 02:30:53 EDT
This is still happening in banshee 2.6 in Fedora 18
Comment 2 Ismael Olea 2013-04-17 05:27:54 EDT
Fedora doesn't include mono-upnp requirement for this feature.

I'll give it a try.
Comment 3 Ismael Olea 2013-04-18 16:59:48 EDT
I made a quick dirty hack: http://olea.org/tmp/banshee-upnp/

I don't have a real upnp enviroment to check if it's really working. Compiling is fine but I would like to be sure the feature really works before submitting mono-upnp to Fedora.

Would you mind to try it and give some feedback here, please?
Comment 4 javiermon 2013-04-18 18:02:09 EDT
Hi

I've switched to fedora 19 and i'm using x86_64, can you provide those packages to test? Also, you could install rygel to do some testing with banshee.

thanks,
Comment 5 Ismael Olea 2013-04-21 14:21:05 EDT
Seems I can't build x86_64 with mock in a i386 machine.

I can give you all srpm's if you would build by yourself.

The good news are I found a 0.1.2 release and seems to find right the dlna services running in the same machine. The plugin outputs some warnings but seems to be minimaly stable. So I'll work for a Fedora package.
Comment 6 Ismael Olea 2013-04-30 07:40:54 EDT
After several tests, including compiling banshee's master (2.7.0) I've found the upnp plugin es very unestable and brokes banshee.

IMO is not useful to add a feature which would break the user experience.

Anyway, I encourage you to work with upstream[1] to stabilize it, since it's a desirable feature.

[1] https://github.com/mono/mono-upnp

Note You need to log in before you can comment on or make changes to this bug.