Bug 833211 - Fix Memory Leak in IMAP SSL/TLS Connections
Fix Memory Leak in IMAP SSL/TLS Connections
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: dbmail (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 17:35 EDT by Harley
Modified: 2014-03-12 13:27 EDT (History)
1 user (show)

See Also:
Fixed In Version: dbmail-3.0.2-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 13:27:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dbmail git patch (1.81 KB, patch)
2012-06-18 17:35 EDT, Harley
no flags Details | Diff
dbmail git patch for el6 branch (1.82 KB, patch)
2012-06-18 17:41 EDT, Harley
no flags Details | Diff

  None (edit)
Description Harley 2012-06-18 17:35:31 EDT
Created attachment 592760 [details]
dbmail git patch

In dbmail 3.0.2 there's a relatively severe memory leak that's caused by the ssl structure never being released after a connection is finished. This has been fixed upstream with this commit: http://git.dbmail.eu/paul/dbmail/commit/?id=7dcf55a92098ed8a12bbc210889948d0195bdee4

Since the fix was already incorporated upstream, it would be nice if the patch could be applied to this package version until a release happens upstream.

I've attached the updated spec and patch.
Comment 1 Harley 2012-06-18 17:41:18 EDT
Created attachment 592761 [details]
dbmail git patch for el6 branch

This is against the el6 branch where-as the other patch is against the master branch.
Comment 2 Bernard Johnson 2014-02-23 02:02:55 EST
Anything above 3.0.2 requires a schema change, so a newer version may never be forthcoming unless some automatic schema upgrade is devised.
Comment 3 Fedora Update System 2014-02-23 02:18:15 EST
dbmail-3.0.2-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dbmail-3.0.2-3.el6
Comment 4 Fedora Update System 2014-02-24 00:58:31 EST
Package dbmail-3.0.2-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing dbmail-3.0.2-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0651/dbmail-3.0.2-3.el6
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-03-12 13:27:32 EDT
dbmail-3.0.2-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.