Bug 833321 - Remove "Education" category from menu entry
Remove "Education" category from menu entry
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 04:39 EDT by Christoph Wickert
Modified: 2012-06-19 20:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 20:12:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for spec file (2.06 KB, patch)
2012-06-19 04:39 EDT, Christoph Wickert
no flags Details | Diff
Patch for spec file (2.06 KB, patch)
2012-06-19 04:55 EDT, Christoph Wickert
no flags Details | Diff

  None (edit)
Description Christoph Wickert 2012-06-19 04:39:56 EDT
Created attachment 592865 [details]
Patch for spec file

Description of problem:
In the gnumeric.spec, desktop-file-install is used to add the "Office" category to the menu entry, but the original category "Education" is not removed, so gnumeric shows up in the menu twice. 

I think Education needs to be removed and it seems that many people agree with me, e.g. the author of the Fedora 17 Xfce Spin review at http://www.dedoimedo.com/computers/fedora-17-xfce.html

Version-Release number of selected component (if applicable):
gnumeric-1:1.11.3-2

Additional info:
If you are ok with the changes I did, I will apply them and build a new package (for rawhide only at this point).
Comment 1 Christoph Wickert 2012-06-19 04:55:32 EDT
Created attachment 592874 [details]
Patch for spec file

Actually the category that needs to be removed is "Science", not "Education". Fixed patch accordingly.
Comment 2 Julian Sikorski 2012-06-19 13:07:42 EDT
Go for it. As a side note, isn't this something worth pushing upstream?
Comment 3 Christoph Wickert 2012-06-19 20:12:11 EDT
(In reply to comment #2)
> Go for it. 

Done. http://koji.fedoraproject.org/koji/taskinfo?taskID=4178603
I think rawhide is enough for now.

> As a side note, isn't this something worth pushing upstream?

Well, I can see how "Science" makes sense for Gnumeric, so I guess it is hard to argue with upstream. The problem is not obvious in gnome-shell and given that we added one category ourselves, we should just remove the other one ourselves, too.

Note You need to log in before you can comment on or make changes to this bug.