This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 833347 - cpglockd init script is not added to chkconfig db
cpglockd init script is not added to chkconfig db
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 05:31 EDT by Fabio Massimo Di Nitto
Modified: 2013-02-21 05:18 EST (History)
2 users (show)

See Also:
Fixed In Version: rgmanager-3.0.12.1-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:18:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2012-06-19 05:31:34 EDT
Description of problem:

rgmanager spec file is missing a couple of bits related to cpglockd handling.

Specifically:

%post
/sbin/chkconfig --add rgmanager

the post section should add:
/sbin/chkconfig --add cpglockd

otherwise chkconfig --list does not show cpglockd.

----

%preun
if [ "$1" = 0 ]; then
        /sbin/service rgmanager stop >/dev/null 2>&1
        /sbin/chkconfig --del rgmanager
fi

once rgmanager is stopped and removed at uninstall time, the same should be done for cpglockd.

both issues are minor.
Comment 1 RHEL Product and Program Management 2012-07-10 01:51:11 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:49:40 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 8 errata-xmlrpc 2013-02-21 05:18:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0409.html

Note You need to log in before you can comment on or make changes to this bug.