Bug 833354 - alternatives support for mpich2
alternatives support for mpich2
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: mpich2 (Show other bugs)
el5
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 05:47 EDT by Christos Triantafyllidis
Modified: 2012-06-19 06:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 06:51:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christos Triantafyllidis 2012-06-19 05:47:18 EDT
Description of problem:
It looks like the mpich2 package is owning the /usr/bin/mpiexec file which is actually an alternatives target. I think that this is not the indented way of packaging tools with alternatives support as if more than one packages do so, a conflict between them is created.


Version-Release number of selected component (if applicable):
mpich2-1.2.1p1-1, it seems that in koji there is a successful build for 1.4.1p1 but this is in trashcan. This version removes alternative support according to the changelog. (I hope that it doesn't own this file as the name is too generic to be owned by a specific package).

How reproducible:
Every time


Steps to Reproduce:
# rpm -qf /usr/bin/mpiexec
  
Actual results:
mpich2-1.2.1p1-1.el5

Expected results:
file /usr/bin/mpiexec is not owned by any package

like the case of java keytool which supports alternatives:
# rpm -qf /usr/bin/keytool 
file /usr/bin/keytool is not owned by any package

Additional info:
none
Comment 1 Christos Triantafyllidis 2012-06-19 06:51:44 EDT
Ooops i just found out that "%ghost" is used in files section of .spec.

For some reason i believed that %ghost files doesn't appear in rpm -qf output.

Closing this ticket as a won't fix.

Sorry for the inconvenience this may have caused.

Note You need to log in before you can comment on or make changes to this bug.