Bug 833382 - [Scale] PM configuration during host installation sometime fails due to a race
[Scale] PM configuration during host installation sometime fails due to a race
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: mkublin
Rami Vaknin
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 07:15 EDT by Rami Vaknin
Modified: 2016-02-10 14:02 EST (History)
10 users (show)

See Also:
Fixed In Version: si21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2012-06-19 07:15:33 EDT
Environment:
RHEV-M SI4

Scenario:
I've installed 36 hosts with power management configuration using python sdk script.
Each host installation followed by power management configuration which done right after the host installation has started.

The issue is that in each cycle of running that script - all the hosts are installed successfully however there are always several hosts (different hosts in each cycle) that fail to get updated with the power management configuration.

From engine.log:
2012-06-19 12:10:31,371 ERROR [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp--0.0.0.0-8009-8) [2aee8b99] Field uniqueID can not be updated when status is Installing
2012-06-19 12:10:31,373 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp--0.0.0.0-8009-8) [2aee8b99] ObjectIdentityChecker.IsUpdateValid:: Not updatable field 'uniqueID' was updated
2012-06-19 12:10:31,374 WARN  [org.ovirt.engine.core.bll.UpdateVdsCommand] (ajp--0.0.0.0-8009-8) [2aee8b99] CanDoAction of action UpdateVds failed. Reasons:VDS_STATUS_NOT_VALID_FOR_UPDATE,VAR__ACTION__UPDATE,VAR__TYPE__HOST
2012-06-19 12:10:31,376 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--0.0.0.0-8009-8) Operation Failed: [Cannot edit Host. Host parameters cannot be modified while Host is operational.
Please switch Host to Maintenance mode first.]
Comment 1 mkublin 2012-10-11 03:59:18 EDT
http://gerrit.ovirt.org/#/c/8485/
Comment 2 mkublin 2012-10-11 04:17:40 EDT
pushed upstream
Comment 4 Rami Vaknin 2012-10-18 18:16:43 EDT
Verified on SI21.
I've installed 38 hosts with power management using the same script, all of them passed successfully.

Note You need to log in before you can comment on or make changes to this bug.