Bug 83340 - cvs_acls from CVS 1.11.2 doesn't work with Perl 5.8
cvs_acls from CVS 1.11.2 doesn't work with Perl 5.8
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cvs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Ben Levenson
http://ccvs.cvshome.org/source/browse...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-02 17:37 EST by Ville Skyttä
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version: cvs-1.11.5-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 16:45:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2003-02-02 17:37:19 EST
The cvs_acls script from CVS 1.11.2 does not work with Perl 5.8, it generates
errors like this:

Split loop at /usr/share/cvs/contrib/cvs_acls line 148, <AVAIL> line 7.
cvs commit: Pre-commit check failed
cvs [commit aborted]: correct above errors first!

The fix is a no-brainer, and is already in CVS versions 1.11.3+.
Please apply, the fix is at 
<http://ccvs.cvshome.org/source/browse/ccvs/contrib/cvs_acls.in.diff?r1=1.3&r2=1.4&f=u>
Comment 1 Ville Skyttä 2003-08-20 16:45:59 EDT
cvs-1.11.5-3 in rawhide includes the fix.

Note You need to log in before you can comment on or make changes to this bug.