Bug 83340 - cvs_acls from CVS 1.11.2 doesn't work with Perl 5.8
Summary: cvs_acls from CVS 1.11.2 doesn't work with Perl 5.8
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Ben Levenson
URL: http://ccvs.cvshome.org/source/browse...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-02 22:37 UTC by Ville Skyttä
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version: cvs-1.11.5-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 20:45:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2003-02-02 22:37:19 UTC
The cvs_acls script from CVS 1.11.2 does not work with Perl 5.8, it generates
errors like this:

Split loop at /usr/share/cvs/contrib/cvs_acls line 148, <AVAIL> line 7.
cvs commit: Pre-commit check failed
cvs [commit aborted]: correct above errors first!

The fix is a no-brainer, and is already in CVS versions 1.11.3+.
Please apply, the fix is at 
<http://ccvs.cvshome.org/source/browse/ccvs/contrib/cvs_acls.in.diff?r1=1.3&r2=1.4&f=u>

Comment 1 Ville Skyttä 2003-08-20 20:45:59 UTC
cvs-1.11.5-3 in rawhide includes the fix.


Note You need to log in before you can comment on or make changes to this bug.