Bug 833406 - sosreport missing brctl output
sosreport missing brctl output
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryn M. Reeves
David Kutálek
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2012-06-19 08:35 EDT by Stanislav Kozina
Modified: 2014-09-15 20:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: sos-1.7-9.67.el5
Doc Type: Bug Fix
Doc Text:
Cause: Previous sos versions did not include the output of the 'brctl' command for all systems. Consequence: Information on bridged network configurations was only available in the report tarball on systems using Xen for virtualization. Fix: The networking module now collects the output of 'brctl show' as well as 'brctl showstp' for each configured bridge. Result: Bridged network configuration information is now available in the report tarball for all hosts.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:31:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Kozina 2012-06-19 08:35:43 EDT
Description of problem:

Missing 'brctl show' output in sosreport on RHEL5

Version-Release number of selected component (if applicable):

Any RHEL5

How reproducible:

Always

Steps to Reproduce:
1. sosreport
2.
3.
  
Actual results:

Missing brctl_show

Expected results:

brctl_show present

Additional info:

None
Comment 1 RHEL Product and Program Management 2012-06-19 08:48:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 Bryn M. Reeves 2012-06-19 09:02:12 EDT
Thanks for the report! This data is collected in RHEL6 by the networking module (in RHEL5 it was unfortunately added only for Xen configurations).

We can certainly backport that functionality to RHEL5 in the next available update but we will also discuss this upstream as it relates to a lot of the data restructuring that we would like to do upstream and we have some other changes required there (e.g. bug 833170 was just filed for a problem with sos and biosdevname-named devices - we _must_ address that asap as the ethN naming assumption has been on the extinction list for a long time).

Anyway, we can certainly do a minimal fix for this even if the long term stuff is not ready in time for the next RHEL5 sos update.
Comment 7 errata-xmlrpc 2014-09-15 20:31:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1200.html

Note You need to log in before you can comment on or make changes to this bug.