Bug 83341 - redhat-config-users does not delete user's home directory
redhat-config-users does not delete user's home directory
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 85338 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-02-02 17:41 EST by Peter van Egdom
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-11 22:13:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhat-config-users diff (419 bytes, patch)
2003-02-08 14:53 EST, Jay Turner
no flags Details | Diff

  None (edit)
Description Peter van Egdom 2003-02-02 17:41:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030121

Description of problem:
Deleting a user (with a home directory) with "redhat-config-users" and answering
'yes'
to the question 'Do you want to delete the user's home directory?' returns the
following
to the shell where "redhat-config-users" has been started :

Traceback (most recent call last):
  File "/usr/share/redhat-config-users/mainWindow.py", line 632, in
on_delete_activate
    rmrf (homeDir + '/' + file)
NameError: global name 'rmrf' is not defined



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use "useradd -m testuser" to make a user called testuser with /home/testuser.
2. start "redhat-config-users" 
3. delete the 'testuser' account
4. answer 'yes' to 'Do you want to delete the user's home directory?'

Actual Results:  Traceback (most recent call last):
  File "/usr/share/redhat-config-users/mainWindow.py", line 632, in
on_delete_activate
    rmrf (homeDir + '/' + file)
NameError: global name 'rmrf' is not defined

Expected Results:  The user and the home directory of the user should have been
deleted.

Additional info:

redhat-config-users-1.1.4-1
Red Hat Linux release 8.0.93 (Phoebe)
Comment 1 Brent Fox 2003-02-04 15:23:13 EST
Should be fixed in redhat-config-users-1.1.4-2.  QA, please verify.
Comment 2 Jay Turner 2003-02-07 14:02:25 EST
[root@jkt3 root]# rpm -q redhat-config-users
redhat-config-users-1.1.5-1

[root@jkt3 root]# redhat-config-users
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/mainWindow.py", line 625, in
on_delete_activate
    rmrf(homeDir)
NameError: global name 'rmrf' is not defined
Comment 3 Brent Fox 2003-02-07 14:12:24 EST
Oops.  Should be fixed for real with redhat-config-users-1.1.5-2.  Sorry about
that typo.
Comment 4 Jay Turner 2003-02-08 14:53:02 EST
Created attachment 89948 [details]
redhat-config-users diff
Comment 5 Jay Turner 2003-02-08 14:53:39 EST
1.1.5-2 is still broken.  Diff for fix attached above.
Comment 6 Brent Fox 2003-02-10 13:20:40 EST
1.1.5-2 behaves correctly for me on my test machine.  Can you show me the
machine that is having the problem?
Comment 7 Brent Fox 2003-02-10 14:13:21 EST
redhat-config-users-1.1.5-3 should pull in the fix.  Sorry about that.
Comment 8 Jay Turner 2003-02-11 08:19:42 EST
OK, really not sure what is happening here, but the code is still borked.  For
some reason the change in mainWindow.py isn't making it into CVS.  Here's the
snip from the 1.1.5-3 source:

  for file in files:
            if os.path.isdir(path + '/' + file):
                rmrf (path + '/' + file)
            else:
Comment 9 Brent Fox 2003-02-11 12:03:10 EST
All right.  Please try with 1.1.5-4.  
Comment 10 Jay Turner 2003-02-11 22:13:15 EST
Fix confirmed with redhat-config-users-1.1.5-4.
Comment 11 Brent Fox 2003-05-23 01:42:07 EDT
*** Bug 85338 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.