Bug 833449 - Alt accelerators do not work in GUI
Alt accelerators do not work in GUI
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-19 09:30 EDT by J.C. Molet
Modified: 2012-06-19 13:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 13:31:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2012-06-19 09:30:50 EDT
Description of problem:
The "Alt" accelerators in the new subscription-manager-gui menu system do not work and are misleading.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.4-1.git.3.1768f90.el5

How reproducible:
always

Steps to Reproduce:
1. Open up subscription-manager-gui
2. Use Alt+s to open the system menu (or Alt+h for help)
3. Attempt to use the alt accelerator of any of their sub-items. (eg: Alt+q for quit)
  
Actual results:
The alt accelerators do nothing for the sub-menu items.

Expected results:
Because the menu item has an underlined letter, you would normally assume that the letter hints at it's alt+accelerator.

There are two possible acceptable solutions for this:
1) Enable the alt+accelerator items so that they work as expected. I think this would be the best solution as many other gnome programs also use this.

--OR-- 

2) Remove the underlines on the accelerator letters.  Since every menu item also lists out its alternate Ctrl+ accelerator next to it, the users still have a keyboard shortcut they can use.

I could see arguments for either solution, but my vote is for 1).
Comment 1 RHEL Product and Program Management 2012-06-19 09:47:56 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 William Poteat 2012-06-19 13:31:31 EDT
Second level menus use single letter without the use of Alt. This is consistent with other programs.

Note You need to log in before you can comment on or make changes to this bug.