Bug 833455 - Brother HL-2170W not working, it has worked before
Brother HL-2170W not working, it has worked before
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 09:51 EDT by Josef Bacik
Modified: 2012-06-20 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 13:20:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
troubleshooting info (32.54 KB, text/plain)
2012-06-20 11:03 EDT, Josef Bacik
no flags Details

  None (edit)
Description Josef Bacik 2012-06-19 09:51:22 EDT
This is on

cups-1.5.2-12.fc17.x86_64

Basically nothing prints, things just end up in the queue and sits there.  When I first installed this box with F16 it worked fine, and then an update broke it, and then an update fixed it, and then an update broke it and it has been broken for the entirety of F17.  I have no idea what the package versions were when it worked/didn't work, I just assumed it would get fixed again, but it's been a while and I'd really like to be able to print to the printer.

I just checked and my netbook which is F15 works fine, it's cups-1.4.8-5.fc15.
Comment 1 Jiri Popelka 2012-06-19 11:05:44 EDT
Can you try to print some postscript and pdf via lpr, i.e.
'lpr file.ps' and 'lpr file.pdf' ?

If postscript succeeds (while pdf fails) then it's dupe of bug #827632 (no patch so far).
Comment 2 Josef Bacik 2012-06-19 12:25:07 EDT
Neither work.
Comment 3 Jiri Popelka 2012-06-20 02:50:45 EDT
Could you attach an output from printing troubleshooter then ?
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
Comment 4 Josef Bacik 2012-06-20 11:03:44 EDT
Created attachment 593233 [details]
troubleshooting info

Here you go.
Comment 5 Jiri Popelka 2012-06-20 12:20:02 EDT
'device-uri': u'dnssd://Brother%20HL-2170W%20series._printer._tcp.local/',
'printer-state-message': u'Unable to locate printer.',

Can you check firewall ?
'service iptables stop' eventually 'service firewalld stop'
Comment 6 Josef Bacik 2012-06-20 13:20:16 EDT
Hrm that made me go look at the uri, not sure how it got that way but I deleted the printer and just re-added the thing with the IP address and it all auto-discovered properly and I could print properly.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.