Bug 833469 - [ALL LANG] Subscription manager GUI : Registration Screen Not translated
[ALL LANG] Subscription manager GUI : Registration Screen Not translated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-19 10:18 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:55:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Register window untranslated (46.85 KB, image/png)
2012-06-19 10:21 EDT, Sharath Dwaral
no flags Details
The subscription-manager server selection dialog is now translated (67.51 KB, image/png)
2012-10-19 17:36 EDT, John Sefler
no flags Details

  None (edit)
Description Sharath Dwaral 2012-06-19 10:18:02 EDT
Description of problem:

When "Register" button is clicked, the registration string that appears is not translated

Version-Release number of selected component (if applicable):

RHEL 5.9
# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.4-1.git.0.0fe81f8.el5
subscription-manager-1.0.4-1.git.0.0fe81f8.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.0.0fe81f8.el5
subscription-manager-firstboot-1.0.4-1.git.0.0fe81f8.el5


How reproducible:
100%

Steps to Reproduce:
1. LANG=es_ES.UTF8 subscription-manager-gui  (any language)
2. Click on Register icon
  
Actual results:
Contents of the window are not translated

Expected results:
Contents of the window are to b localised

Additional info:
Screnshot attached
Comment 1 Sharath Dwaral 2012-06-19 10:21:44 EDT
Created attachment 592974 [details]
Register window untranslated
Comment 3 RHEL Product and Program Management 2012-06-19 16:48:39 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Devan Goodwin 2012-10-03 10:59:35 EDT
I have verified this problem still exists with latest strings.

The register screen strings *are* marked for translation, and indeed are translated in other languages. (example pt_BR)

Really not sure why they're missing in es_ES.
Comment 5 Devan Goodwin 2012-10-03 11:16:20 EDT
bkearney noticed that the strings are translated in 5.9 branch, just not in master. Going to look into this but otherwise we can consider this closed.


Note: the screen has changed dramatically since this bug was filed to the attached screenshot will be quite different.
Comment 7 John Sefler 2012-10-19 17:36:40 EDT
Created attachment 630256 [details]
The subscription-manager server selection dialog is now translated

Attached is an example of the translated subscription-manager server selection dialog.  This sample screenshot was taken using LANG=te_IN
[root@jsefler-rhel59 ~]# LANG=te_IN.UTF8 subscription-manager-gui

Notice that the design of this dialog has been modified from the original captured screenshot.

Notice this translator decided not to translate "hostname[:port][/prefix]" which is okay.

Moving to VERIFIED
Comment 9 errata-xmlrpc 2013-01-07 22:55:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.