Bug 833502 - Evdev right click emulation don't work on touch screen
Evdev right click emulation don't work on touch screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 11:36 EDT by Iybego
Modified: 2012-06-19 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 21:32:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iybego 2012-06-19 11:36:01 EDT
Description of problem:
Evdev right-click emulation don't work only on touchscreen, e.g. emulation works well on mouse. 

Version-Release number of selected component (if applicable):
kernel-3.4.2-4.fc17.x86_64
xorg-x11-drv-evdev-2.7.0.fc17.x86_64

How reproducible:
Enable "Evdev Third Button Emulation", and try to do right click on touchscreen by holding finger.

Additional info:
Comment 1 Peter Hutterer 2012-06-19 21:32:43 EDT
this is actually intended. for true multitouch screens we don't do gesture interpretation in the driver and leave it up to the client stack to do so. this of course leaves us with a gap until the clients all support it properly, but the alternative is a mess (as the synaptics driver shows). sorry.

Note You need to log in before you can comment on or make changes to this bug.