Bug 833512 - [fix available] Clicking gnome-panel launcher icons derived from OpenOffice.org .desktop files doesn't launch LibreOffice after upgrade
[fix available] Clicking gnome-panel launcher icons derived from OpenOffice.o...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.4
Assigned To: Caolan McNamara
Desktop QE
:
Depends On:
Blocks: 960054
  Show dependency treegraph
 
Reported: 2012-06-19 11:57 EDT by Caolan McNamara
Modified: 2013-11-21 05:00 EST (History)
1 user (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: Backward compatibility links for the first released OpenOffice.org version on RHEL-6 removed from LibreOffice. Consequence: Old OpenOffice.org gnome-panel launcher icons not migrated to LibreOffice Fix: restore compatibility links Result: Old launcher icons work again
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 05:00:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2012-06-19 11:57:45 EDT
Description of problem:
Clicking gnome panel icons derived from OpenOffice.org .desktop files doesn't launch LibreOffice instead

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Starting with OpenOffice.org installed
2. Drag from applications->office->writer onto toolbar
3. Clicking the toolbar will launch OpenOffice.org
4. Upgrade to Libreoffice
5. Now click the toolbar icon
  
Actual results:
Failed to execute child process "openoffice.org-1.9"

Expected results:
LibreOffice launches instead

Additional info:
We dropped the compatibility 1-9.desktop files in F-10, but RHEL-6 precedes that release so we should restore them there.
Comment 1 RHEL Product and Program Management 2012-07-10 04:45:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:49:54 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 RHEL Product and Program Management 2012-09-07 01:37:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2013-11-21 05:00:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1594.html

Note You need to log in before you can comment on or make changes to this bug.