Bug 833519 - uvcvideo issue with kernel 3.5.0-rc2 and rc3
uvcvideo issue with kernel 3.5.0-rc2 and rc3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
uvcvideo first=3.5.0-0.rc0.git9.2 tes...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 12:10 EDT by Martin Kho
Modified: 2013-07-04 18:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 16:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (66.32 KB, text/plain)
2012-06-19 12:10 EDT, Martin Kho
no flags Details
/var/log/messages (241.28 KB, text/plain)
2012-06-19 12:11 EDT, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2012-06-19 12:10:31 EDT
Created attachment 592999 [details]
dmesg

Description of problem:

My logitech webcam c270 (046d:0825) fails to work with these kernels. In Fedora 17 it functions okay. It looks like a regression in the usb-code or uvc-driver [1]

When I remove the webcam the kernel crashes with the following message:
"khubd/21 is trying to acquire lock". See further /var/log/messages.

[1] http://www.spinics.net/lists/linux-media/msg49077.html

Version-Release number of selected component (if applicable):
3.5.0-0.rc2.git0.1.fc18.x86_64
3.5.0-0.rc2.git0.3.fc18.x86_64
3.5.0-0.rc3.git0.2.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. boot system --> see messages in dmesg
2. run kamoso (KDE) or Cheese (Gnome) -> no webcam
3. see dmesg -> probe of webcam fails
  
Actual results:
no webcam

Expected results:
light webcam turns on, kamoso/cheese shows image

Additional info:
In /var/log/message you'll see that systemd-udevd taints the kernel. In the output it seems to be related to the sound system e.g card1. That's the microphone of the webcam.

Note: I'v added messages from the crash and the current running/latest kernel in one messages file. dmesg is from the latest kernel.
Comment 1 Martin Kho 2012-06-19 12:11:09 EDT
Created attachment 593000 [details]
/var/log/messages
Comment 2 Josh Boyer 2012-06-19 12:54:33 EDT
Which F17 kernels work?  Specifically, do the F17 3.4 kernel updates function correctly?
Comment 3 Martin Kho 2012-06-19 13:08:04 EDT
Hi Josh,

All kernels - now running 3.4.2-4.fc17.x86_64 - have been working fine. No errors in /var/log/messages and dmesg.


Martin Kho
Comment 4 Martin Kho 2012-06-20 05:29:45 EDT
Hi,

I've checked some older /var/log/messages - /var/log/messages-20120610 - and saw that the first kernel that showed the issues is 3.5.0-0.rc0.git9.2.fc18.x86_64. This kernel was the first one that was installed after upgrading the stable Fedora 17 KDE-liveCD. 3.5.0-0.rc2.git0.1 is the oldest kernel that is currently installed.

Hope this helps.

Martin Kho
Comment 5 Martin Kho 2012-07-15 04:47:14 EDT
Hi,

FYI: Upstream bugreport [1] comment #6 speaks of a discussion on the alsa-devel list. A fix would land in mainstream soon.

HTH

Martin Kho


[1] https://bugzilla.kernel.org/show_bug.cgi?id=44281
Comment 6 Martin Kho 2012-07-15 04:51:35 EDT
Hi,

Pressed somewhat too quick on Save Changes :-)

From [1] comment #54 it seems that kernel v3.5-rc7 contains a fix. As soon this kernel lands in rawhide I'll let you know if it works for me.


Martin Kho

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1018020
Comment 7 Martin Kho 2012-07-17 16:06:42 EDT
Hi,

Kernel-3.5.0-0.rc7.git0.1.fc18.x86_64 indeed solved this issue. This report can be closed.

Thanks,

Martin Kho
Comment 8 Josh Boyer 2012-07-17 16:21:49 EDT
Thank you for letting us know.  Your persistence in the bug is appreciated.

Note You need to log in before you can comment on or make changes to this bug.