Bug 833558 - Custom compile of 3.4.2-4 fails due to empty req.list; patch to put protection in kernel.spec attached
Custom compile of 3.4.2-4 fails due to empty req.list; patch to put protectio...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 836121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 14:59 EDT by stan
Modified: 2012-08-09 13:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 12:47:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for the kernel.spec in the kernel src.rpm to prevent choke on empty req.list (745 bytes, text/plain)
2012-06-19 14:59 EDT, stan
no flags Details

  None (edit)
Description stan 2012-06-19 14:59:12 EDT
Created attachment 593041 [details]
Patch for the kernel.spec in the kernel src.rpm to prevent choke on empty req.list

Description of problem:  Compiling a highly customized kernel from the src.rpm fails at the rpm build stage because the req.list of additional module dependencies is empty.  The sort chokes.


Version-Release number of selected component (if applicable):
3.4.2-4

How reproducible:
Every time for the custom compile.

Steps to Reproduce:
1.Customize the src.rpm kernel configuration
2.rpmbuild
3.
  
Actual results:
sort -u rpm.list > rpm2.list in the kernel spec %build section fails with an empty file.

Expected results:
rpms are created.

Additional info:  I am including this as documentation of the problem in case anyone else encounters it.  I doubt that this will ever affect the Fedora stock kernel.  Putting the patch in place won't cause any problems for the stock kernel build though.
Comment 1 Josh Boyer 2012-07-03 10:32:32 EDT
*** Bug 836121 has been marked as a duplicate of this bug. ***
Comment 2 Josh Boyer 2012-07-20 12:47:14 EDT
Thank you for the patch.  There are a couple of issues with it though.

The same failure can happen with the dep.list sort if both of your conditions fail and mod-extra3.list winds up being an empty file.  Also, if mod-extra.list doesn't exist the 'cp %{SOURCE16}' a few lines above would fail.  It would also mean that essentially the modules-extra package is disabled and we really screwed up somewhere.

I solved this instead by making sure the needed files exist via touch before they are used.
Comment 3 stan 2012-08-09 13:05:02 EDT
You would be more familiar than I am with what is needed.  And so it proves.  Your fix works fine in my custom compile of 3.5.0-2.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.