Bug 833655 - After suspending host, all VMs are pinned to CPU 0
After suspending host, all VMs are pinned to CPU 0
Status: CLOSED DUPLICATE of bug 714271
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 00:12 EDT by Josh Adams
Modified: 2012-06-20 05:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 05:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Adams 2012-06-20 00:12:23 EDT
Description of problem:
Using virt-manager to create and manage VMs (qemu-kvm), it seems that once the host has been suspended all VMs are pinned to CPU 0 upon resume.  Obviously, this causes some serious performance issues.  I am not necessarily sure if libvirt is at fault here, but I have not been able to find much by searching for this problem.

Version-Release number of selected component (if applicable):
virt-manager-0.9.1-4.fc17
libvirt-0.9.11.3-1.fc17
qemu-kvm-1.0-17.fc17

How reproducible:
Every time

Steps to Reproduce:
1. Create a VM in virt-manager
2. Suspend the host computer
3. Resume the host computer
4. Click on the "Show virtual hardware details" (lightbulb) button
5. Click on Processor
6. Click on "Pinning"
  
Actual results:
VCPU    On CPU    Pinning
0       0           0
1       0           0

Expected results:
VCPU    On CPU    Pinning
0       (any cpu)   0,1,2,3
1       (any cpu)   0,1,2,3

Additional info:
I don't remember this always having happened in the past, but it has been happening atleast since Fedora 16.
Comment 1 Daniel Berrange 2012-06-20 05:51:45 EDT

*** This bug has been marked as a duplicate of bug 714271 ***

Note You need to log in before you can comment on or make changes to this bug.