Bug 833687 - manpage says e1000 is the default nic (default is rtl8139)
manpage says e1000 is the default nic (default is rtl8139)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: alpha
: ---
Assigned To: Karen Noel
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 03:09 EDT by xiali
Modified: 2013-02-21 02:37 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.321.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:37:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiali 2012-06-20 03:09:56 EDT
Description of problem:
qemu-kvm's manpage said "The NIC is an e1000 by default on the PC target." But it's 8139, which makes network not working sometimes.


Version-Release number of selected component (if applicable):
Name        : qemu-kvm
Arch        : x86_64
Epoch       : 2
Version     : 0.12.1.2
Release     : 2.295.el6


How reproducible:
100%


Steps to Reproduce:
1. create a virt system, keep the nic option default
2. start it
3. lspci or ethtool
  
Actual results:
the nic is 8139

Expected results:
the nic is e1000

Additional info:
this issue affects virt-manager, and happens in Fedora 17. btw, kernel's default option doesn't include 8139 driver...
Comment 2 Ademar Reis 2012-06-20 17:38:08 EDT
Avi: you reverted the default to rtl8139 in RHEL (not upstream):

commit 6025b2d198f9f6ad0304272df6d78659b86c880a
Author: Avi Kivity <avi@redhat.com>
Date:   Mon Aug 31 14:14:40 2009 +0300

    Revert back to rtl8139 as default nic
    
    e1000 is not supported well on Windows XP.
    
    Signed-off-by: Avi Kivity <avi@redhat.com>

Adam (comment #0) says this doesn't work, so should we re-revert back to e1000 or should we fix the manpage?
Comment 3 Avi Kivity 2012-06-24 09:51:37 EDT
The change is not in RHEL, but in qemu-kvm.git.

rtl8139 works fine in Linux.
Comment 4 xiali 2012-06-24 21:50:55 EDT
(In reply to comment #3)
> The change is not in RHEL, but in qemu-kvm.git.
> 
> rtl8139 works fine in Linux.

No, rt8139 doesn't work fine in all linux. Compiling kernel with defconfig, the bzImage generated supports e1000 but not rt8139. 

And I don't think we should apply that non-upstream patch, WinXP users can set nic model by themself.

If you still insist, please keep the manpage and behavior same at least.

Thank you.
Comment 5 Avi Kivity 2012-06-25 10:16:58 EDT
defconfig is irrelevant, no one uses it for anything.  Nor am I about to break Windows XP out-of-the-box experience.
Comment 6 xiali 2012-06-25 21:17:33 EDT
Maybe I didn't make myself clear.

I mean, if you still insist rt8139, please change the manpage too.

QEMU can be a tool for OS developing, keeping the manpage and behavior same is important in that way.
Comment 7 Ademar Reis 2012-06-26 08:29:35 EDT
(In reply to comment #6)
> Maybe I didn't make myself clear.
> 
> I mean, if you still insist rt8139, please change the manpage too.

Adam, that's why I changed the bug description and kept it open: the manpage should be fixed.
Comment 8 RHEL Product and Program Management 2012-07-10 02:05:43 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2012-07-10 21:45:44 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 13 mazhang 2012-11-12 02:57:07 EST
Reproduced this bug on: qemu-kvm-0.12.1.2-2.295.el6.x86_64

Steps to Reproduce:
1. create a virt system, keep the nic option default
2. start it
3. lspci or ethtool

Actual results:
1.virt-manager generate command line by nic option default:
/usr/libexec/qemu-kvm -S -M rhel6.3.0 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name asdf -uuid e14efda3-eebe-d63c-0a9d-a2009ff0dc95 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/asdf.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-reboot -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/libvirt/images/asdf.img,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/home/iso/Fedora-17-x86_64-DVD.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -netdev tap,fd=21,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:e2:c0:9d,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -vnc 127.0.0.1:1 -vga cirrus -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5
2.lspci in guest found nic is 8139

3.man page:
Create a new Network Interface Card and connect it to VLAN n (n = 0
           is the default). The NIC is an e1000 by default on the PC target.



Verified this bug on: qemu-kvm-0.12.1.2-2.334.el6.x86_64

Actual results:
1.virt-manager generate command line by nic option default:
/usr/libexec/qemu-kvm -name asdf -S -M rhel5.4.0 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid f62b63c0-722e-f7f6-05df-2041d6b64582 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/asdf.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-reboot -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/libvirt/images/asdf.img,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -netdev tap,fd=22,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:7f:65:a2,bus=pci.0,addr=0x3,bootindex=1 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -vnc 127.0.0.1:0 -vga cirrus -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

2.lspci in guest found nic is 8139

3. man page:
...
Create a new Network Interface Card and connect it to VLAN n (n = 0
           is the default). The NIC is an rtl8139 by default on the PC target.

so this bug was fixed.
Comment 17 errata-xmlrpc 2013-02-21 02:37:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.