Bug 833700 - [rhevm] - temp log files are being created periodically at /tmp (tmp.4P5WDqMKt4 )
[rhevm] - temp log files are being created periodically at /tmp (tmp.4P5WDqMK...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Juan Hernández
David Botzer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 03:22 EDT by David Botzer
Modified: 2016-02-10 14:38 EST (History)
9 users (show)

See Also:
Fixed In Version: si7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
folder (961 bytes, application/x-gzip)
2012-07-26 07:46 EDT, David Botzer
no flags Details
new-tmp (58.72 KB, application/octet-stream)
2012-07-26 07:48 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-06-20 03:22:57 EDT
Description of problem:
On the rhevm server every couple of minutes many temp.xxxx files are being created

Version-Release number of selected component (if applicable):
rhevm 3.1/si6

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
at /tmp look for tmp.xxx files

Expected results:
should be deleted in terms of 1sec-10sec and not get accumalated
or should not be created at all

Additional info:
* Juan had already pushed a fix for that.


cat tmp.5L8FqJ79Ay
  insert into
  schema_version(version,script,checksum,installed_by,started_at,ended_at,state,current,comment)

                       values
  (trim('03010410'),'upgrade/03_01_0410_remove_image_templates_table.sql','a1af5216e9e08e5b458d7196a8fc30ca','engine',

                       cast(trim(' 2012-06-17 10:02:18.785785+03') as
  timestamp),cast(trim(' 2012-06-17 10:02:18.874122+03') as
  timestamp),'INSTALLED',false,'');
Comment 1 David Botzer 2012-06-20 03:23:57 EDT
It was seen on rhevm 3.0, though less periodically.
Comment 2 Juan Hernández 2012-06-20 04:04:32 EDT
I detected an issue with the database creation scripts some time ago, and I think this is the same. The problem is that the database creation scripts create one temporary file for each upgrade, and they are never deleted:

The change I proposed to fix the issue is here:

http://gerrit.ovirt.org/#/c/5041

It has already been merged.
Comment 3 David Botzer 2012-07-16 09:08:23 EDT
SI10 - Still happening
Some files are 5 days old...

cat tmp.JrRv0w9oVh
insert into schema_version(version,script,checksum,installed_by,started_at,ended_at,state,current,comment)
                     values (trim('03000130'),'upgrade/03_00_0130_remove_unused_columns.sql','e5088a4c9242e98ab4b9f97d8566f093','postgres',
                     cast(trim(' 2012-07-15 15:18:26.862234+03') as timestamp),cast(trim(' 2012-07-15 15:18:26.983036+03') as timestamp),'INSTALLED',false,'');
Comment 4 David Botzer 2012-07-26 07:45:18 EDT
3.1/si11
Still getting tmp files of all kind , now new ones -
See attached
Comment 5 David Botzer 2012-07-26 07:46:17 EDT
Created attachment 600491 [details]
folder
Comment 6 David Botzer 2012-07-26 07:48:34 EDT
Created attachment 600493 [details]
new-tmp
Comment 7 Juan Hernández 2012-07-26 08:08:58 EDT
These new tmp files are apparently related to reports. Yaniv, can you take a look?
Comment 8 Yaniv Lavi (Dary) 2012-07-26 08:34:53 EDT
These are the reports setup temp files.
Why do we need to clean these?
Comment 9 David Botzer 2012-07-30 05:20:18 EDT
Yaniv,
if the tmp files dont get to often and too large of space, it will be deleted eventually
so there is no problem from my side

Please advise on the frequent of these tmp files that are created,
Comment 10 David Botzer 2012-07-30 05:31:01 EDT
Fixed, 3.1/si12
The reports tmp files are created only during setup
And are small sized
Fixed, 3.1/si12

Note You need to log in before you can comment on or make changes to this bug.