Bug 833744 - The lists of emails are not displayed dismissed senders/recipients.
The lists of emails are not displayed dismissed senders/recipients.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 04:55 EDT by Mikhail
Modified: 2012-07-09 02:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 04:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (172.98 KB, image/png)
2012-06-20 04:55 EDT, Mikhail
no flags Details
Why I couldn't see some senders in list??? (338.27 KB, image/png)
2012-06-25 01:06 EDT, Mikhail
no flags Details
compare look screenshot (444.97 KB, image/png)
2012-07-03 11:37 EDT, Mikhail
no flags Details
example message (1.97 KB, application/octet-stream)
2012-07-03 11:54 EDT, Mikhail
no flags Details
proof screenshot (182.84 KB, image/png)
2012-07-03 12:00 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 679305 None None None 2012-07-03 04:16:05 EDT

  None (edit)
Description Mikhail 2012-06-20 04:55:27 EDT
Created attachment 593152 [details]
screenshot

Description of problem:
The lists of emails are not displayed dismissed senders / recipients.
Comment 1 Mikhail 2012-06-20 05:02:58 EDT
This occurs when I use EWS, MAPI not affected.
Comment 2 Mikhail 2012-06-25 01:06:49 EDT
Created attachment 594097 [details]
Why I couldn't see some senders in list???
Comment 3 Milan Crha 2012-06-25 08:30:57 EDT
Thanks for a bug report. I tried to reproduce it with my Exchange 2007 server, but with no luck. I also deleted my local cache and forced full download of the folder summary, but it still shows same information in the message list and message preview panel.

Could you try to delete local mail cache for your ews account and let the evolution-ews recreate it, with turned on debugging, thus we can check if it'll not work, please? You can do that with these steps:
a) close evolution
b) go to ~/.cache/evolution/mail
c) here are directories, each for one of your configured remote mail accounts;
   the one for EWS is that which has folder-tree file in its root.
   Rename the folder to something else (or you can even delete it, there are
   stored only local copies of messages from the remote server).
d) run evolution from terminal with this command:
   $ EWS_DEBUG=2 evolution &>log.txt
e) let evolution fetch folder information and message list for your Inbox, and
   then check any of the messages from your screen shot, whether they'll still
   show some values empty in the folder tree, but filled in the message
   preview panel.
f) close evolution (thus the log will be properly closed).

Keep the log.txt file for later use, we'll decide what to do with it based on your findings in e). Thanks in advance.
Comment 4 Mikhail 2012-06-26 03:28:17 EDT
I sent log directly to your mail
Comment 5 Milan Crha 2012-06-27 09:53:59 EDT
Thanks for the log (it's pretty long). I tried to find the email shown in comment #0, but that address is not part of the log. I also tried to find the email from comment #2, but no luck either. There are few messages from that person, but none seems to be the same as the one from the screenshot.

Is it possible the log doesn't contain messages downloaded from the Inbox folder?  (Please do not clear the local cache again, it's OK. When you enter folder you were not in yet, then a new log will contain messages/communication only from that folder). Also, I suppose the redownload didn't fix the issue, did it?

I deleted the log from my mail account and expunged the folder.
Comment 6 Milan Crha 2012-06-27 10:20:28 EDT
I just got an idea, after seeing yours bug #835593 and bug #835761, can this be related to your network issues, as I see in bug #835761 comment #0 quite many times:
> (evolution:1570): camel-ews-provider-WARNING **: Unable to fetch the folder
> hierarchy: No response: Cannot connect to destination (cherry2.afbank.ru)
> :288

Because, if you got disconnected unexpectedly, in the middle of message summary fetch, then it's possible the evolution-ews stored the last change key and used it the next time, thus the message summary was not updated properly. That might also mean that local cache purge and full redonwload of it should fix message summary (in case you didn't hit the network outage again).
Comment 7 Mikhail 2012-07-02 10:16:36 EDT
> Also, I suppose the redownload didn't fix the issue, did it?
Yes

> Because, if you got disconnected unexpectedly, in the middle of message
> summary fetch, then it's possible the evolution-ews stored the last change
> key and used it the next time, thus the message summary was not updated
> properly. That might also mean that local cache purge and full redonwload of it
> should fix message summary (in case you didn't hit the network outage again).

Also full redownload bot help me.
Comment 8 Mikhail 2012-07-02 10:16:50 EDT
> Also, I suppose the redownload didn't fix the issue, did it?
Yes

> Because, if you got disconnected unexpectedly, in the middle of message
> summary fetch, then it's possible the evolution-ews stored the last change
> key and used it the next time, thus the message summary was not updated
> properly. That might also mean that local cache purge and full redonwload of it
> should fix message summary (in case you didn't hit the network outage again).

Also full redownload not help me.
Comment 9 Mikhail 2012-07-02 10:21:15 EDT
> I tried to find the email shown in comment #0, but that address is not part of the log

I found this message by time

<t:DateTimeSent>2010-04-05T09:29:34Z</t:DateTimeSent>
<t:DateTimeCreated>2010-04-05T09:29:35Z</t:DateTimeCreated>


please look log again
Comment 10 Milan Crha 2012-07-03 03:50:39 EDT
I see. The server returned empty Subject (I thought it's a bug too):
   <t:Subject/>
but ToRecipients, together with Sender and From are filled. The difference might be that the RoutingType is EX, instead of SMTP. The EX is an Exchange address type, not an email address.
Comment 11 Mikhail 2012-07-03 04:05:35 EDT
> The server returned empty Subject (I thought it's a bug too)
No really empty subject in this example.

I also attach original message from outlook and screenshot.
Comment 12 Mikhail 2012-07-03 04:07:09 EDT
Created attachment 595899 [details]
msg from outlook
Comment 13 Mikhail 2012-07-03 04:08:16 EDT
Created attachment 595900 [details]
Outlook screenshot
Comment 14 Milan Crha 2012-07-03 04:16:05 EDT
That's what the server returns, empty Subject. I see in the screenshot that the Tema is also empty, and the Outlook msg, when I skip couple of binary data, I see in headers "Subject:". We see the same thing on all machines, except of From/To.

I searched my server folders and found one such message too, thus I can confirm this. I moved this upstream as [1], for better visibility and bug reference.
Please see [1] for any further updates. And thanks for your patience and all the debugging information.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=679305
Comment 15 Milan Crha 2012-07-03 10:11:35 EDT
I created a test build with the upstream patch included at [1]. It should work, but I would like to know if also on your side. The only thing is that this applies to newly downloaded messages only, thus you'll need to remove your local cache again.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=4216091
Comment 16 Mikhail 2012-07-03 11:37:10 EDT
It seems working, I see now all the senders, but
This is correctly, that I see EX addresses instead email adress???
Comment 17 Mikhail 2012-07-03 11:37:52 EDT
Created attachment 595998 [details]
compare look screenshot
Comment 18 Mikhail 2012-07-03 11:54:13 EDT
Also returns old problem with messages which haven't smtp address :(
Comment 19 Mikhail 2012-07-03 11:54:52 EDT
Created attachment 596000 [details]
example message
Comment 20 Mikhail 2012-07-03 11:58:50 EDT
Differences between 799820 and today, that in this case "From" field is empty.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=799820
Comment 21 Mikhail 2012-07-03 12:00:19 EDT
Created attachment 596003 [details]
proof screenshot
Comment 22 Milan Crha 2012-07-04 06:22:24 EDT
(In reply to comment #16)
> It seems working, I see now all the senders, but
> This is correctly, that I see EX addresses instead email adress???

They are there only in case it could not be resolved into SMTP address. I can do it same as Outlook does, do not bother you with EX address when SMTP was not found (aka show only sender's name). I'm wondering what will happen if you reply to the message in outlook, will it eventually resolve the name to some address? It probably can do that, the question is what will be used for the resolution, either EWS or MAPI.

(In reply to comment #20)
> Differences between 799820 and today, that in this case "From" field is
> empty.

Oh, I see. I added requirement for non-empty email in the mailbox resolution. I'll revert it and provide updated test package.
Comment 23 Milan Crha 2012-07-04 07:37:03 EDT
Here's another test build, with both upstream patches included:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4217991
Comment 24 Mikhail 2012-07-04 11:59:12 EDT
https://docs.google.com/open?id=0B0nwzlfiB4aQWFJBNDhneVlISUE

> They are there only in case it could not be resolved into SMTP address.
> I can do it same as Outlook does, do not bother you with EX address when SMTP
> was not found (aka show only sender's name). I'm wondering what will
> happen if you reply to the message in outlook, will it eventually resolve
> the name to some address? It probably can do that, the question is what
> will be used for the resolution, either EWS or MAPI.

Whence appear smtp address when I press reply button?
Outlook does not yet show smtp addresses in the list and it is unclear at what point he receives them. But there is no difference in work between EX and ordinary contacts in Outlook. Also on the video can be seen that when I do reply, Evolution inserts only smtp address in field "From", and Outlook inserts a contact from address book.
Comment 25 Milan Crha 2012-07-09 02:08:57 EDT
Ah, I see, I forgot they open their composer with autocompleted contacts, where evolution doesn't do this.

The search in GAL from the end of the video, the issue is with the way EWS invokes searches, it does search only if email is chosen, thus if you click the magnifier icon on the left of the search entry and change to the second item, to "Email begins with", then only there will be a search done. That's a separate issue from this one, I think it's already filled upstream.

Note You need to log in before you can comment on or make changes to this bug.