Bug 833772 - 3.1 - prepareForShutdown is not executed when connection to libvirt is broken
3.1 - prepareForShutdown is not executed when connection to libvirt is broken
Status: CLOSED DUPLICATE of bug 834041
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Gal Hammer
Haim
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 06:40 EDT by vvyazmin@redhat.com
Modified: 2014-07-01 07:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 03:16:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm and libvirtd logs (999.82 KB, application/x-gzip)
2012-06-20 06:40 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-06-20 06:40:53 EDT
Created attachment 593173 [details]
vdsm and libvirtd logs

Description of problem:
prepareForShutdown is not executed when connection to libvirt is broken (libvirtError: Cannot write data: Broken pipe)

Version-Release number of selected component (if applicable):
vdsm-4.9.6-16.0.el6.x86_64

Actual results:
1. In RHEVM --> Hosts tab --> host in “unassigned” status.
2. VDSM not “recreate” a new connection, in case of connection to LIBVIRT is broken.

Expected results:
1. In RHEVM --> Hosts tab --> host in “up” status.
2. VDSM “recreate” a new connection, in case of connection to LIBVIRT is broken.

Workaround:
# /etc/init.d/vdsmd restart
Comment 2 Barak 2012-07-15 11:51:52 EDT
Please provide libvirt logs (reason for being down) & vdsm logs.

How did you use the prepareForShutdown ? through vdsmCli ?
Comment 3 Haim 2012-07-16 03:16:09 EDT
(In reply to comment #2)
> Please provide libvirt logs (reason for being down) & vdsm logs.
> 
> How did you use the prepareForShutdown ? through vdsmCli ?

no, vdsm should take itself down on such case, anyhow, its a duplicate bug,

*** This bug has been marked as a duplicate of bug 834041 ***

Note You need to log in before you can comment on or make changes to this bug.