Bug 833787 - ovirt-engine-backend: we are able to add a disk during create snapshot
ovirt-engine-backend: we are able to add a disk during create snapshot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity high
: ---
: 3.1.0
Assigned To: mkublin
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 07:16 EDT by Dafna Ron
Modified: 2016-02-10 12:14 EST (History)
9 users (show)

See Also:
Fixed In Version: SI8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (27.01 KB, application/x-xz)
2012-06-20 07:16 EDT, Dafna Ron
no flags Details
log (2.48 KB, application/x-xz)
2012-06-25 10:22 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-20 07:16:57 EDT
Created attachment 593180 [details]
log

Description of problem:

since snapshot is on entire vm and not just the disks, and we cancelled the image lock on vm during snapshot we should add a CanDoAction on add disk while disk images are locked due to snapshot to prevent possible races which will cause image corruption. 

Version-Release number of selected component (if applicable):

si6

How reproducible:

100%

Steps to Reproduce:
1. create a snapshot
2. create a new disk
3.
  
Actual results:

vm is not locked only disk images and there is no CanDoAction -> new disk will be created while a snapshot is taken. 

Expected results:

we should add CanDoAction to add disk if the disk images are locked due to snapshot. 

Additional info:backend log
Comment 1 mkublin 2012-06-20 07:31:13 EDT
http://gerrit.ovirt.org/#/c/5528/
Comment 2 Dafna Ron 2012-06-25 10:22:04 EDT
not solved 
I was still able to create the disk while snapshot was created. 
logs attached
Comment 3 Dafna Ron 2012-06-25 10:22:38 EDT
Created attachment 594196 [details]
log
Comment 4 mkublin 2012-06-26 02:51:29 EDT
I don't see any problm at logs, just clog for creating disk
Comment 5 mkublin 2012-06-27 03:28:45 EDT
recheck at si8, I suppose the fix was not there
Comment 6 Dafna Ron 2012-07-01 11:30:47 EDT
verified on si8

Note You need to log in before you can comment on or make changes to this bug.