This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 833808 - [abrt] libreoffice-core-3.5.4.2-1.fc17: memcpy: Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.4.2-1.fc17: memcpy: Process /usr/lib/libreoffice/...
Status: CLOSED DUPLICATE of bug 831628
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:bfa4fa822987cc06f5c84809b51...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 08:00 EDT by cstent
Modified: 2012-06-20 08:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (79.64 KB, text/plain)
2012-06-20 08:01 EDT, cstent
no flags Details
File: maps (37.43 KB, text/plain)
2012-06-20 08:01 EDT, cstent
no flags Details
File: dso_list (11.63 KB, text/plain)
2012-06-20 08:01 EDT, cstent
no flags Details

  None (edit)
Description cstent 2012-06-20 08:00:59 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --quickstart --nologo --nodefault
crash_function: memcpy
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.4.2-4.fc17.i686
pid:            2007
pwd:            /home/cstent
time:           Wed 20 Jun 2012 02:29:01 PM EEST
uid:            1000
username:       cstent
xsession_errors: 

backtrace:      Text file, 81555 bytes
dso_list:       Text file, 11907 bytes
maps:           Text file, 38329 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/cstent/2

core_backtrace:
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x13ec83 __memcpy_ssse3 libc.so.6 -
:445ed23c5e2816f00a0a006d765c5aa03041f41c 0x22a3c rtl_copyMemory libuno_sal.so.3 -
:bc28344fe986f949a9684b988f52a564dd433d1d 0x297cb - libvclplug_genlo.so -
:445ed23c5e2816f00a0a006d765c5aa03041f41c 0x13124 - libuno_sal.so.3 -
:abcfe6b280fcee6f1f127d40d8f54e6b4d896f5a 0x6adf start_thread libpthread.so.0 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0xf155e clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=PtolemaiosII.survey.ntua.gr
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/cstent/keyring-uPLx45/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=72edfb90d84d1ac0593f5dec0000001a-1340182522.564452-1195441044
:OLDPWD=/usr/lib/libreoffice/program
:QTDIR=/usr/lib/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/cstent/keyring-uPLx45
:QTINC=/usr/lib/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=cstent
:DESKTOP_AUTOSTART_ID=1012b37cee44e54348134018252387748500000014840006
:SSH_AUTH_SOCK=/run/user/cstent/keyring-uPLx45/ssh
:USERNAME=cstent
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1484,unix/unix:/tmp/.ICE-unix/1484
:MAIL=/var/spool/mail/cstent
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/cstent/.local/bin:/home/cstent/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/cstent
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1478
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/cstent
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=cstent
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-sqZUEY2O2c,guid=44f58eef99160cd553c3db3d00000043
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/cstent
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-cstent-G5IhgA/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 24111                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       24111                24111                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/cstent/.xsession-errors
:pos:	29246
:flags:	02002
:2:/home/cstent/.xsession-errors
:pos:	29246
:flags:	02002
:3:socket:[31250]
:pos:	0
:flags:	02004002
:4:pipe:[25512]
:pos:	0
:flags:	00
:5:pipe:[25512]
:pos:	0
:flags:	01
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[31936]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[31938]
:pos:	0
:flags:	02004002
:10:socket:[31952]
:pos:	0
:flags:	02000002

smolt_data:
:
:
:General
:=================================
:UUID: eb0c16d2-ede7-4c91-ad1a-f4ec6f4f2b6c
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 5999.82
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E6850  @ 3.00GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2999
:System Memory: 3030
:System Swap: 5087
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.4.2-4.fc17.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:955:4318:3157) pci, pcieport, PCI/PCI, C55 PCI Express bridge
:(4318:620:4163:33353) pci, snd_hda_intel, MULTIMEDIA, MCP51 High Definition Audio
:(4318:623:4318:52100) pci, None, PCI/PCI, MCP51 PCI Bridge
:(4318:612:4163:33212) pci, nForce2_smbus, SERIAL, A8N-VM CSM Mainboard
:(4318:608:4163:33212) pci, None, PCI/ISA, A8N-VM CSM Mainboard
:(4318:931:0:0) pci, None, HOST/PCI, C55 Host Bridge
:(4318:937:0:0) pci, None, RAM, C55 Memory Controller
:(4318:938:0:0) pci, None, RAM, C55 Memory Controller
:(4318:947:0:0) pci, None, RAM, C55 Memory Controller
:(4318:946:0:0) pci, None, RAM, C55 Memory Controller
:(4318:945:0:0) pci, None, RAM, C55 Memory Controller
:(4318:944:0:0) pci, None, RAM, C55 Memory Controller
:(4318:943:0:0) pci, None, RAM, C55 Memory Controller
:(4318:942:0:0) pci, None, RAM, C55 Memory Controller
:(4318:941:0:0) pci, None, RAM, C55 Memory Controller
:(4318:940:0:0) pci, None, RAM, C55 Memory Controller
:(4318:949:0:0) pci, None, RAM, C55 Memory Controller
:(4318:948:0:0) pci, None, RAM, C55 Memory Controller
:(6523:9056:4163:33288) pci, ahci, STORAGE, JMB360 AHCI Controller
:(4318:939:0:0) pci, None, RAM, C55 Memory Controller
:(4318:617:4163:33313) pci, forcedeth, BRIDGE, MCP51 Ethernet Controller
:(4318:936:0:0) pci, None, RAM, C55 Memory Controller
:(4318:950:0:0) pci, None, RAM, C55 Memory Controller
:(4318:956:0:0) pci, None, RAM, C55 Memory Controller
:(4318:954:0:0) pci, None, RAM, C55 Memory Controller
:(4318:951:4318:3157) pci, pcieport, PCI/PCI, C55 PCI Express bridge
:(4318:626:4163:33212) pci, None, RAM, MCP51 Memory Controller 0
:(4318:1057:0:0) pci, nouveau, VIDEO, G86 [GeForce 8500 GT]
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(4318:613:4163:33212) pci, pata_amd, STORAGE, A8N-VM CSM Mainboard
:(4318:624:4163:33212) pci, None, RAM, A8N-VM CSM Mainboard
:(4318:614:4163:33212) pci, sata_nv, STORAGE, A8N-VM CSM Mainboard
:(4318:615:4163:33212) pci, sata_nv, STORAGE, A8N-VM CSM Mainboard
:(4318:621:4163:33212) pci, ohci_hcd, USB, A8N-VM CSM Mainboard
:(4318:622:4163:33212) pci, ehci_hcd, USB, A8N-VM CSM Mainboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_ptolemaiosii-lv_root / ext4 4096 4096 13092026 8326019 8194987 3276800 2798135 2798135
:/dev/sda2 /boot ext4 1024 1024 508745 407002 381402 128016 127708 127708
:/dev/mapper/vg_ptolemaiosii-lv_home /home ext4 4096 4096 107435201 73661556 68283918 26894336 26808913 26808913
:

var_log_messages:
:Jun 19 18:23:53 PtolemaiosII kernel: [ 1515.037046] soffice.bin[2105]: segfault at 0 ip 44cb8c83 sp b4d7f128 error 6 in libc-2.15.so[44b7a000+1a8000]
:Jun 19 18:23:54 PtolemaiosII abrt[4334]: Saved core dump of pid 1984 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-06-19-18:23:53-1984 (40198144 bytes)
:Jun 20 14:29:01 PtolemaiosII kernel: [ 9286.036221] soffice.bin[2161]: segfault at 0 ip 44cb8c83 sp b4deb128 error 6 in libc-2.15.so[44b7a000+1a8000]
:Jun 20 14:29:06 PtolemaiosII abrt[4422]: Saved core dump of pid 2007 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-06-20-14:29:01-2007 (49184768 bytes)
Comment 1 cstent 2012-06-20 08:01:03 EDT
Created attachment 593185 [details]
File: backtrace
Comment 2 cstent 2012-06-20 08:01:05 EDT
Created attachment 593186 [details]
File: maps
Comment 3 cstent 2012-06-20 08:01:08 EDT
Created attachment 593187 [details]
File: dso_list
Comment 4 Stephan Bergmann 2012-06-20 08:18:56 EDT
From the backtrace of attachment 593185 [details] this is the same as bug 831628, the root problem being the ICEConnectionWorker thread still running during exit.

*** This bug has been marked as a duplicate of bug 831628 ***

Note You need to log in before you can comment on or make changes to this bug.