Bug 833851 - segfault in model_row_changed_cb() when saving a new task after network switch
segfault in model_row_changed_cb() when saving a new task after network switch
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.4
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 09:17 EDT by David Jaša
Modified: 2013-07-24 07:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-2.32.3-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 07:12:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evo backtrace (108.10 KB, text/plain)
2012-06-20 09:17 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-06-20 09:17:42 EDT
Created attachment 593206 [details]
evo backtrace

Description of problem:
Got a segfault in model_row_changed_cb() after I saved a new task. I did this after a switch from wired to wireless network.

Version-Release number of selected component (if applicable):
evolution-2.28.3-25.2.el6.x86_64

How reproducible:
didn't try to reproduce

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

these lines from .xsession-errors seem to be related:
(evolution:11062): calendar-gui-WARNING **: Couldn't find event window
(evolution:11062): GLib-GObject-WARNING **: invalid cast from `BonoboDockBand' to `ETasks'

debug variables on the system:
export MALLOC_CHECK_=1
export MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
export G_SLICE=always-malloc,debug-blocks
Comment 1 Milan Crha 2012-06-26 06:47:15 EDT
Thanks for a bug report. I see in the backtrace just what you said, you are closing tasks editor, when on of the EBook is freeing, the bonobo stuff decides to deliver server-side notification, like that one task had been modified. This notification is propagated through ECalView down to ECalModelTasks, which has this model_row_changed_cb() signal handler connected and it is invoked. The thing is that this handler is assigned only once, the first time this is crated, with passed-in ETasks, thus this seems like memory overwrite from somewhere. Kind of exact steps will be helpful to identify the issue.

Upstream bug report is [1], but it is closed as obsolete and never was fixed.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=589568
Comment 2 RHEL Product and Program Management 2012-07-10 02:34:55 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 19:09:32 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-12-14 02:07:27 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Milan Crha 2013-06-10 08:44:11 EDT
David, could you retest this, please? The best if you'll use the official evolution packages.
Comment 7 Milan Crha 2013-07-24 07:12:54 EDT
I spoke with David on IRC and he told me that he didn't see this since the rebase, thus I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.