Bug 833859 - [OSS] broker and node unable to reboot due to configuration is not persistent.
[OSS] broker and node unable to reboot due to configuration is not persistent.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 09:28 EDT by Johnny Liu
Modified: 2015-05-14 21:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-06-20 09:28:13 EDT
Description of problem:
Following http://www.krishnaraman.net/multi-node-openshift-origin-from-scratch/ to setup Multi-node OpenShift Origin PaaS from scratch.

After multi-node env is setup, broker and node machine can not be rebooted, once reboot, the multi-node env is broken.
for broker, after reboot, named can not be started up due to /var/named/forwarders.conf syntax error, looks like forwarders.conf is restored after reboot.

and /etc/resolve.conf will be re-writen by dhclient.

From now on, user must re-run ss-setup-broker, ss-setup-node and ss-register-dns commands.

We need figure out a method to make these configuration persistent.

BTW, in the instruction, 
3. Restart the node environment so that it can start services

If user follow this, due to /etc/resolve.conf is re-writen, that will cause mcolective connection is broken.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Krishna Raman 2012-06-20 16:31:39 EDT
Fixed. However, if reboot causes the IP address of broker or node to change then you will need to run the setup scripts again.
Comment 2 Peter Ruan 2012-06-21 00:28:23 EDT
verified by rebooting my nodes multiple times and they come back everytime.

Note You need to log in before you can comment on or make changes to this bug.