Bug 8340 - Cbq support still missing (QoS stuff)
Cbq support still missing (QoS stuff)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
All Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-10 13:42 EST by Milan Kerslager
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 08:39:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2000-01-10 13:42:50 EST
As I reported early (but I can't find my old bug report here in Bugzilla)
cbq module support is still missing in kernel. As we have shapecfg package
in distribution we should have cbq (and maybe other "QoS and/or fair
queueing modules") modules in kernel package to allow cbq script from
shapecfg package to work properly.
The only one problem is that you should compile the kernel with the proper
compiler because some of them break these modules.
Comment 1 Milan Kerslager 2000-06-22 17:04:44 EDT
Is there any reason to not include QoS to RPM??? This is extremly uncomfortable.
Comment 2 Doug Ledford 2000-06-22 20:13:40 EDT
Alan, should the QoS kernel options and the advanced router options be enabled
in the 2.2 kernels?  The 2.4 kernels?
Comment 3 Doug Ledford 2000-06-22 20:49:42 EDT
Alan bounced this to you Dave....
Comment 4 David Miller 2000-06-23 09:47:26 EDT
I see no reason why we should not enable the packet scheduler
modules, we ship all the tools (tc, shapecfg, etc.) and I'm confident
in Alexey's work.  This goes for both 2.2.x and 2.4.x kernels.

After some thinking, I believe the advanced router stuff should
be enabled in both kernels as well.  All of this stuff is well
maintained and rather stable.
Comment 5 Milan Kerslager 2000-08-16 08:11:34 EDT
As there is shapecfg package in standard distribution, kernel should support it.
Please, enable QoS in the kernel.
Comment 6 Michael K. Johnson 2000-08-21 20:10:20 EDT
Done in current source tree.
Comment 7 Pekka Savola 2001-03-03 17:03:06 EST
Mucking around with 2.4.2-0.1.16, it seems QoS options have all been disabled. Was there some reason for this?

I think it'd be great to see QOS stuff in the kernel, built as modules.

Reopening..
Comment 8 Arjan van de Ven 2001-03-05 08:39:49 EST
enabled the modules again

Note You need to log in before you can comment on or make changes to this bug.