Bug 834020 - 3.1 - [setupNetworks] Check connectivity: net config not rolled back
3.1 - [setupNetworks] Check connectivity: net config not rolled back
Status: CLOSED DUPLICATE of bug 835900
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Kenigsberg
Haim
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 11:37 EDT by Alona Kaplan
Modified: 2014-01-12 19:52 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 10:54:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (9.91 MB, text/x-log)
2012-06-20 11:38 EDT, Alona Kaplan
no flags Details

  None (edit)
Description Alona Kaplan 2012-06-20 11:37:29 EDT
Description of problem:
Moving the management network to an unconnected nic when check-connectivity is checked causes losing connection from the host to the engine.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
Preconditions-
1. The host have at least two nics.
2. One of the nics doesn't have connectivity to the engine.

Steps-
1. Open the SetupNetworks form (Hosts->Network interfaces)
2. Drag the management network to the nic that doesn't have connectivity to the engine.
3. Make sure that the "Verify connectivity between Host and ovirt-engine" (check connectivity) is checked.
4. Make sure "Save Network configuraion" is unchecked.
5. Press ok

  
Actual results:
1. The connectivity from the manager to the host is lost
2. The host keeps the new configuration
3. service vdsmd restart, returns the host to the last saved configuration and the connectivity to the engine returns. 

Expected results:
1. The host rollbacks the change after timeout (60000 ms) and doesn't lose connectivity to the engine.


Additional info:
Comment 1 Alona Kaplan 2012-06-20 11:38:38 EDT
Created attachment 593254 [details]
vdsm log
Comment 2 Meni Yakove 2012-06-27 10:54:27 EDT

*** This bug has been marked as a duplicate of bug 835900 ***

Note You need to log in before you can comment on or make changes to this bug.