Bug 834023 - mailman archiver messes up on From in mail content
mailman archiver messes up on From in mail content
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailman (Show other bugs)
6.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 11:49 EDT by Kevin Fenzi
Modified: 2012-11-20 08:43 EST (History)
4 users (show)

See Also:
Fixed In Version: mailman-2.1.12-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: "Form" string in emails body was not escaped properly. Consequence: Message containing "Form" string in the beginning of line was splitted and showed in web archive as two or more messages. Fix: "From" string is now escaped. Result: Message like that is now showed in web archive as single email.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 08:43:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (5.03 KB, patch)
2012-07-26 02:03 EDT, Jan Kaluža
no flags Details | Diff

  None (edit)
Description Kevin Fenzi 2012-06-20 11:49:37 EDT
When sent a email with: 

"

From whatever"

(ie, a blank line and a line that starts with "From ", mailman's archiver seems to correctly escape the 
From in the mbox file to ">From " but it doesn't seem to handle showing that correctly in the date or thread lists for the mailing list archive. 

Example: 

https://fedorahosted.org/pipermail/aeolus-devel/2012-June/010794.html
https://fedorahosted.org/pipermail/aeolus-devel/2012-June/010795.html

That is one email, and there's one line between those two archive entries. 

>From what I saw of the original conversation, we're looking to build our community and evangelize Aeolus' strengths.
Comment 2 seth vidal 2012-06-20 12:04:30 EDT
this bug seems to be the first fix

https://bugs.launchpad.net/mailman/+bug/266068

then this bug seems to be an ammendment to that fix

https://bugs.launchpad.net/mailman/+bug/265967

either way  - we need a patch in what's in rhel.
Comment 3 Justin Clift 2012-07-25 07:54:29 EDT
Bumped the priority and severity of this, as it's directly causing broken email archives on public fedorahosted.org.
Comment 5 Jan Kaluža 2012-07-26 02:03:53 EDT
Created attachment 600439 [details]
proposed patch

Note that it replaces current mailman-2.1.9-header-folding.patch
Comment 10 Jan Kaluža 2012-07-31 06:58:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: "Form" string in emails body was not escaped properly.

Consequence: Message containing "Form" string in the beginning of line was splitted and showed in web archive as two or more messages.

Fix: "From" string is now escaped.

Result: Message like that is now showed in web archive as single email.
Comment 11 Justin Clift 2012-07-31 08:01:28 EDT
The technical note should also direct places experiencing the problem (ie corrupted email archives) in how to reprocess their mailbox files to fix things.
Comment 14 errata-xmlrpc 2012-11-20 08:43:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1474.html

Note You need to log in before you can comment on or make changes to this bug.