Bug 834034 - 3.1: Cannot complete the Node (Fedora 17) installation - It stuck in oVirt Engine with 'Reboot' status but the node doesn't reboot
3.1: Cannot complete the Node (Fedora 17) installation - It stuck in oVirt En...
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.1 RC
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Haim
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 13:04 EDT by Douglas Schilling Landgraf
Modified: 2014-01-12 19:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 15:16:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Schilling Landgraf 2012-06-20 13:04:34 EDT
Description of problem:

I am using Fedora 17 as Node, disabled selinux feature and I have tried to deploy the node. However, it failed with the following error.

Log: /tmp/vds_bootstrap_complete.20120619_002652.log

2012-06-19 00:26:52,979 DEBUG    vds_bootstrap_complete_46dfc402-4d65-4b6e-a525-55ff1c49e585 81 installVirtualizationService = 'True', installGlusterService = 'False'
2012-06-19 00:26:52,979 DEBUG    deployUtil 1154 instCert: start. num=46dfc402-4d65-4b6e-a525-55ff1c49e585
2012-06-19 00:26:52,981 DEBUG    deployUtil 1165 instCert: try to delete old certificates
2012-06-19 00:26:52,982 DEBUG    deployUtil 1168 instCert: install new certificates
2012-06-19 00:26:52,984 DEBUG    deployUtil 1207 instCert: ended.
2012-06-19 00:26:52,984 DEBUG    deployUtil 186 setCoreDumpPath started.
2012-06-19 00:26:52,984 DEBUG    deployUtil 122 ['/bin/echo', '/var/lib/vdsm/core', '>', '/proc/sys/kernel/core_pattern']
2012-06-19 00:26:52,986 DEBUG    deployUtil 126 /var/lib/vdsm/core > /proc/sys/kernel/core_pattern

2012-06-19 00:26:52,986 DEBUG    deployUtil 127 
2012-06-19 00:26:52,986 DEBUG    deployUtil 195 setCoreDumpPath end:True
2012-06-19 00:26:52,986 DEBUG    deployUtil 226 cleanAll end:True
2012-06-19 00:26:52,986 DEBUG    deployUtil 236 setVdsConf: started. config:ssl=true;management_port=54321
2012-06-19 00:26:52,987 DEBUG    deployUtil 257 setVdsConf: setting Key=ssl to val=true
2012-06-19 00:26:52,987 DEBUG    deployUtil 705 _updateFileLine: entry. File: /etc/vdsm/vdsm.conf key=ssl value=true
2012-06-19 00:26:52,989 DEBUG    deployUtil 721 _updateFileLine: replacing ssl=true
 with: ssl=true

2012-06-19 00:26:52,991 DEBUG    deployUtil 744 _updateFileLine: return: True
2012-06-19 00:26:52,991 DEBUG    deployUtil 257 setVdsConf: setting Key=management_port to val=54321
2012-06-19 00:26:52,991 DEBUG    deployUtil 705 _updateFileLine: entry. File: /etc/vdsm/vdsm.conf key=management_port value=54321
2012-06-19 00:26:52,995 DEBUG    deployUtil 721 _updateFileLine: replacing management_port=54321
 with: management_port=54321

2012-06-19 00:26:52,995 DEBUG    deployUtil 744 _updateFileLine: return: True
2012-06-19 00:26:52,995 DEBUG    deployUtil 273 setVdsConf: ended.
2012-06-19 00:26:52,995 DEBUG    deployUtil 122 ['/bin/systemctl', 'reconfigure', 'vdsmd.service']
2012-06-19 00:26:52,997 DEBUG    deployUtil 126 
2012-06-19 00:26:52,997 DEBUG    deployUtil 127 Unknown operation reconfigure

2012-06-19 00:26:52,997 DEBUG    deployUtil 122 ['/lib/systemd/systemd-vdsmd', 'reconfigure']
2012-06-19 00:27:44,039 DEBUG    deployUtil 126 Configuring libvirt for vdsm...

2012-06-19 00:27:44,040 DEBUG    deployUtil 127 SELinux:  Could not downgrade policy file /etc/selinux/targeted/policy/policy.27, searching for an older version.
SELinux:  Could not open policy file <= /etc/selinux/targeted/policy/policy.27:  No such file or directory
/sbin/load_policy:  Can't load policy:  No such file or directory
libsemanage.semanage_reload_policy: load_policy returned error code 2.
SELinux:  Could not downgrade policy file /etc/selinux/targeted/policy/policy.27, searching for an older version.
SELinux:  Could not open policy file <= /etc/selinux/targeted/policy/policy.27:  No such file or directory
/sbin/load_policy:  Can't load policy:  No such file or directory
libsemanage.semanage_reload_policy: load_policy returned error code 2.
/usr/sbin/semanage: Could not commit semanage transaction
setsebool:  SELinux is disabled.
setsebool:  SELinux is disabled.

2012-06-19 00:27:44,040 DEBUG    vds_bootstrap_complete_46dfc402-4d65-4b6e-a525-55ff1c49e585 45 Reboot: started.
2012-06-19 00:27:44,040 DEBUG    deployUtil 122 ['/usr/bin/reboot']
2012-06-19 00:27:44,059 ERROR    deployUtil 129 Traceback (most recent call last):
  File "/tmp/deployUtil.py", line 123, in _logExec
  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

2012-06-19 00:27:44,060 DEBUG    vds_bootstrap_complete_46dfc402-4d65-4b6e-a525-55ff1c49e585 57 <BSTRAP component='Reboot' status='OK' message='Rebooting machine' />
2012-06-19 00:27:44,060 DEBUG    vds_bootstrap_complete_46dfc402-4d65-4b6e-a525-55ff1c49e585 61 Reboot: ended.


To reproduce:
================
Add the Node into oVirt Engine, it install the node correctly but when oVirt Engine required the Node to Reboot it doesn't work (node kept running) and the Node status kept as 'Reboot'. 

Reason:
=============
Fedora 17 doesn't have /usr/bin/reboot as Fedora16 

Fedora17 reboot path:
/sbin/reboot or /usr/sbin/reboot

Fedora16 reboot path:
/sbin/reboot or /usr/bin/reboot
Comment 1 Douglas Schilling Landgraf 2012-06-20 14:31:44 EDT
ovirt 3.1 branch:
http://gerrit.ovirt.org/#/c/5565/

upstream:
http://gerrit.ovirt.org/#/c/5566/
Comment 2 Dan Kenigsberg 2012-06-20 14:56:45 EDT
Have you built vdsm-bootstrap on f17? the build process should have found reboot in its new path, right?
Comment 3 Dan Kenigsberg 2012-06-20 15:14:20 EDT
Very odd. vdsm-bootstrap-4.10.0-1.fc17.noarch.rpm seems to have no mention of '/usr/bin/reboot'. Could it be that you've used an .fc16 build?
Comment 4 Douglas Schilling Landgraf 2012-06-20 15:16:57 EDT
Looks like Dan, closing this bug and abandoning the patches for now.

Note You need to log in before you can comment on or make changes to this bug.