Bug 834043 - Problem with rail 3.2.5 and minitest
Problem with rail 3.2.5 and minitest
Status: CLOSED DUPLICATE of bug 829209
Product: Fedora
Classification: Fedora
Component: rubygem-minitest (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 13:35 EDT by Charlie
Modified: 2012-06-22 01:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 01:40:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie 2012-06-20 13:35:31 EDT
Description of problem:
Redmine forces to use rails v 3.2.5

But when I run the webrick server, it shows me an error:

ruby --trace /var/www/redmine/redmine-latest/script/rails server webrick -e production &


*************************************************************************
/usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require': cannot load such file -- minitest/unit (LoadError)
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `block in require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:236:in `load_dependency'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/share/ruby/test/unit/assertions.rb:1:in `<top (required)>'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `block in require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:236:in `load_dependency'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/share/ruby/test/unit/testcase.rb:1:in `<top (required)>'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `block in require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:236:in `load_dependency'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/test_case.rb:1:in `<top (required)>'
	from /usr/local/share/gems/gems/actionpack-3.2.5/lib/action_controller/test_case.rb:334:in `<module:ActionController>'
	from /usr/local/share/gems/gems/actionpack-3.2.5/lib/action_controller/test_case.rb:7:in `<top (required)>'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `block in require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:236:in `load_dependency'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/actionpack-3.2.5/lib/action_view/test_case.rb:5:in `<top (required)>'
	from /usr/local/share/gems/gems/prototype-rails-3.2.1/lib/prototype-rails/on_load_action_view.rb:17:in `<top (required)>'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `block in require'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:236:in `load_dependency'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
	from /usr/local/share/gems/gems/prototype-rails-3.2.1/lib/prototype-rails.rb:12:in `block (2 levels) in <class:Engine>'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/lazy_load_hooks.rb:36:in `instance_eval'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/lazy_load_hooks.rb:36:in `execute_hook'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/lazy_load_hooks.rb:26:in `block in on_load'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/lazy_load_hooks.rb:25:in `each'
	from /usr/local/share/gems/gems/activesupport-3.2.5/lib/active_support/lazy_load_hooks.rb:25:in `on_load'
	from /usr/local/share/gems/gems/prototype-rails-3.2.1/lib/prototype-rails.rb:11:in `block in <class:Engine>'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/initializable.rb:30:in `instance_exec'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/initializable.rb:30:in `run'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/initializable.rb:55:in `block in run_initializers'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/initializable.rb:54:in `each'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/initializable.rb:54:in `run_initializers'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/application.rb:136:in `initialize!'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/railtie/configurable.rb:30:in `method_missing'
	from /var/www/redmine/redmine-2.0.2/2.0.2/config/environment.rb:14:in `<top (required)>'
	from /var/www/redmine/redmine-2.0.2/2.0.2/config.ru:4:in `require'
	from /var/www/redmine/redmine-2.0.2/2.0.2/config.ru:4:in `block in <main>'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/builder.rb:51:in `instance_eval'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/builder.rb:51:in `initialize'
	from /var/www/redmine/redmine-2.0.2/2.0.2/config.ru:1:in `new'
	from /var/www/redmine/redmine-2.0.2/2.0.2/config.ru:1:in `<main>'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/builder.rb:40:in `eval'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/builder.rb:40:in `parse_file'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/server.rb:200:in `app'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/commands/server.rb:46:in `app'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/server.rb:301:in `wrapped_app'
	from /usr/local/share/gems/gems/rack-1.4.1/lib/rack/server.rb:252:in `start'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/commands/server.rb:70:in `start'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/commands.rb:55:in `block in <top (required)>'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/commands.rb:50:in `tap'
	from /usr/local/share/gems/gems/railties-3.2.5/lib/rails/commands.rb:50:in `<top (required)>'
	from /var/www/redmine/redmine-latest/script/rails:6:in `require
-*******************************************************************






Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Checkout redmine 2.0.3 
2.run yum install ruby ruby-devel rubygem-bigdecimal rubygem-minitest bundler
3.'bundle install --without development test postgresql sqlite' on the root folder
4.try to run the webrick server: ruby /var/www/redmine/2.0.3/script/rails server webrick -e production &
  
Actual results: The error above


Expected results: server started, redmine running


Additional info: best regards
Comment 1 Bohuslav "Slavek" Kabrda 2012-06-21 01:13:59 EDT
Hi Charlie,
could you please try out solution mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=829209#c24 and let me know if that works for you?
Thanks.
Comment 2 Charlie 2012-06-21 13:56:44 EDT
Hi,

I forgot this step.

Thank you soooooooooooooooooo much!

Kiss from Paris, Charlie
Comment 3 Bohuslav "Slavek" Kabrda 2012-06-22 01:40:00 EDT
You are welcome :)

*** This bug has been marked as a duplicate of bug 829029 ***
Comment 4 Bohuslav "Slavek" Kabrda 2012-06-22 01:40:57 EDT

*** This bug has been marked as a duplicate of bug 829209 ***

Note You need to log in before you can comment on or make changes to this bug.