Bug 834147 - Beaker will break if distros are imported as ftp:// and not http://
Beaker will break if distros are imported as ftp:// and not http://
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.9
Unspecified Unspecified
low Severity low (vote)
: 0.9.1
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 21:19 EDT by Dan Callaghan
Modified: 2012-07-19 20:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 20:38:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-06-20 21:19:07 EDT
There are a few places where we call DistroTree.url_in_lab(..., 'http') expecting there to always be an http:// URL. But in fact beaker-import will accept ftp:// without http:// and we can use FTP in these cases too. So we should fix the calls.

Marking as low priority because probably everyone will have HTTP (certainly we always do internally).
Comment 1 Dan Callaghan 2012-07-10 02:51:07 EDT
On Gerrit: http://gerrit.beaker-project.org/1195
Comment 5 Dan Callaghan 2012-07-19 20:38:25 EDT
Beaker 0.9.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.