Bug 834156 - rhel7.0 desktop freezes when use default boot or enable "radeon.modeset=1 reboot=pci" in kernel line [NEEDINFO]
rhel7.0 desktop freezes when use default boot or enable "radeon.modeset=1 r...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: rc
: 7.1
Assigned To: X/OpenGL Maintenance List
Desktop QE
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 00:01 EDT by Haichao Zhai
Modified: 2017-07-13 19:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 19:07:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tpelka: needinfo? (hzhai)


Attachments (Terms of Use)
radeon.modeset=0 log (59.18 KB, text/plain)
2012-06-21 00:03 EDT, Haichao Zhai
no flags Details
radeon.modeset=1 log (61.53 KB, text/plain)
2012-06-21 00:04 EDT, Haichao Zhai
no flags Details
lspci-VGA msg (2.90 KB, text/plain)
2012-06-21 00:05 EDT, Haichao Zhai
no flags Details
dmidecode msg (22.79 KB, text/plain)
2012-06-21 00:05 EDT, Haichao Zhai
no flags Details

  None (edit)
Description Haichao Zhai 2012-06-21 00:01:20 EDT
Description of problem:
cann't login host via desktop after install rhel7.0(but both serial console and ssh can login host).I attached dmesg log and VGA info to attachment. If add "radeon.modeset=0 reboot=pci" to kernel line then can login successfully via desktop.

Version-Release number of selected component (if applicable):
# uname -r
3.3.0-0.14.el7.x86_64

build tree
download.englab.nay.redhat.com/pub/rhel/nightly/RHEL-7.0-20120614.n.0

How reproducible:
always

Steps to Reproduce:
1.install rhel7.0 with desktop mode
2.reboot host with runlevel 5(default) 
3.
  
Actual results:
host desktop freezes

Expected results:
can login with desktop and host work well

Additional info:
if boot guest with runlevel 3, still cann't login host.
Comment 1 Haichao Zhai 2012-06-21 00:03:44 EDT
Created attachment 593340 [details]
radeon.modeset=0 log
Comment 2 Haichao Zhai 2012-06-21 00:04:28 EDT
Created attachment 593341 [details]
radeon.modeset=1 log
Comment 3 Haichao Zhai 2012-06-21 00:05:30 EDT
Created attachment 593342 [details]
lspci-VGA msg
Comment 4 Haichao Zhai 2012-06-21 00:05:56 EDT
Created attachment 593343 [details]
dmidecode msg
Comment 6 Jérôme Glisse 2013-12-10 16:29:46 EST
By can't login what do you mean ? Black screen ? Other ? Log says everything is fine.
Comment 7 Jérôme Glisse 2014-03-07 10:25:26 EST
We believe this is already fixed but moving to 7.1
Comment 9 Jérôme Glisse 2014-07-17 11:31:31 EDT
This should already work in 7.0 but reassigning to kernel as if it is an issue than it is a kernel issue.
Comment 12 Tomas Pelka 2015-07-28 08:49:04 EDT
Hiachao would you be able to check with 7.2 kernel, are you still able to reporoduce?

Thanks
-Tom
Comment 15 Oded Gabbay 2016-05-09 11:45:19 EDT
I installed RHEL 7.2.0 on an x86-64 machine with AMD CAICOS GPU installed. The installation was successful and RHEL booted successfully after that. I didn't see any freezes.
Comment 17 Lyude 2017-07-13 19:07:42 EDT
This bug is stale, and it looks like it's been fixed so I'm going to close it. If you're still experiencing issues with this on the latest versions of RHEL, please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.