Bug 834207 - RHEV-H installation process didn't filter out livecd device which managed by multipath
RHEV-H installation process didn't filter out livecd device which managed by ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks: 868163
  Show dependency treegraph
 
Reported: 2012-06-21 04:42 EDT by cshao
Modified: 2016-04-26 10:13 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, the live media being used to install Red Hat Enterprise Virtualization Hypervisor appeared as a possible installation target if the installation media was managed by multipath. Now, installation media is filtered out from the list of possible installation targets.
Story Points: ---
Clone Of:
: 868163 (view as bug list)
Environment:
Last Closed: 2013-02-28 11:37:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
livecd (37.95 KB, image/jpeg)
2012-06-21 04:42 EDT, cshao
no flags Details

  None (edit)
Description cshao 2012-06-21 04:42:30 EDT
Created attachment 593389 [details]
livecd

Description of problem:
RHEV-H installation process didn't filter out livecd device which managed by multipath

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120615.1.el6

How reproducible:
100%

Steps to Reproduce:
1. Make livecd to USB disk (Newer usb sticks: Sandisk 16G) via command:
rhevh-iso-to-disk --format rhevh-6.3-20120615.1.el6.iso /dev/sdb
2. Boot from the livecd.
3. Enter the select disk page in TUI installation process.
 
Actual results:
1. The livecd device (Newer usb sticks) is listed in select disk page.
2. Older USB sticks which isn't management by multipath can be filtered out.

====================================
# multipath -ll
1SanDisk dm-1 SanDisk,Cruzer Edge
size=15G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  `- 0:0:0:0 sda 8:0  active ready running
1ATA_WDC_WD5000AAKS-75V0A0_WD-WCAWF6238839 dm-0 ATA,WDC WD5000AAKS-7
size=466G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
  `- 1:0:0:0 sdb 8:16 active ready running


ovirt-config-installer (lines 457-466)
======================================
Storage = storage.Storage()
        dev_names, self.disk_dict = Storage.get_udev_devices()
        self.displayed_disks = {}
        self.valid_disks = []
        for dev in dev_names:
            dev = translate_multipath_device(dev)
            if not self.displayed_disks.has_key(dev):
                if self.disk_dict.has_key(dev) and dev != self.live_disk:
                    dev_bus,dev_name,dev_size,dev_desc,dev_serial,dev_model = self.disk_dict[dev].split(",",5)
                    dev_desc = pad_or_trim(32, dev_desc)


Can't filter USB stick which managed by multipath (newer usb sticks)
=======================================
 get_live_disk()
'dm-6'
>>> get_live_disk().rstrip('0123456789')
'dm-'


Can filter USB sticks which isn't managed by multipath (older USB sticks)
=======================================
get_live_disk()
'sda1'
>>> dev_name, disk_dict = storage.Storage().get_udev_devices()
>>> print dev_name
['/dev/mapper/1ATA_WDC_WD5000AAKS-75V0A0_WD-WCAWF6238839', '/dev/sda']
>>> get_live_disk().rstrip('0123456789')
'sda'

Expected results:
RHEV-H installation process can filter out all livecd devices.

Additional info:
The same issue occurs in rhevh-6.2-20111117.1.el6, so it isn't a regression bug.
Comment 2 RHEL Product and Program Management 2012-07-10 03:18:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:19 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 10 errata-xmlrpc 2013-02-28 11:37:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.