Bug 834215 - service lm_sensor cannot be started, modprobe: Error: missing parameters. See -h
service lm_sensor cannot be started, modprobe: Error: missing parameters. See -h
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lm_sensors (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: beta
: ---
Assigned To: Jaromír Cápík
Petr Sklenar
:
Depends On:
Blocks: 816135
  Show dependency treegraph
 
Reported: 2012-06-21 05:05 EDT by Petr Sklenar
Modified: 2016-01-31 20:56 EST (History)
3 users (show)

See Also:
Fixed In Version: lm_sensors-3.3.4-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 15:20:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-06-21 05:05:03 EDT
Description of problem:
service lm_sensor cannot be started on the latest rhel7.
are there wrong parameters?

Version-Release number of selected component (if applicable):

lm_sensors-3.3.2-2.el7.ppc64
kmod-7-2.el7.ppc64
systemd-44-12.el7.ppc64


How reproducible:
deterministic

Steps to Reproduce:
1. service lm_sensors start

  
Actual results:
# systemctl start lm_sensors.service
Job failed. See system journal and 'systemctl status' for details.

# systemctl status lm_sensors.service
lm_sensors.service - Initialize hardware monitoring sensors
	  Loaded: loaded (/usr/lib/systemd/system/lm_sensors.service; disabled)
	  Active: failed (Result: exit-code) since Thu, 21 Jun 2012 17:47:35 +0900; 4s ago
	 Process: 3807 ExecStart=/usr/bin/sensors -s (code=exited, status=1/FAILURE)
	 Process: 3805 ExecStart=/sbin/modprobe -qab $BUS_MODULES $HWMON_MODULES (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/lm_sensors.service

Jun 21 17:47:35 MY.X.Y.Z.redhat.com modprobe[3805]: Error: missing parameters. See -h.


Expected results:
service is started

Additional info:
Comment 3 Jaromír Cápík 2013-07-25 10:06:53 EDT
Ahoj Petře.

It seems you haven't run the sensors-detect script in order to generate the variables. This also happens when no sensors are detected by the script.

It's questionable if this is a correct behaviour or not. It has no sense to start the service without configuring it first. And it has no sense to run the service when there are no sensors detected.

Please, check that and let me know.

Thanks,
Jaromir.
Comment 4 Jaromír Cápík 2013-07-30 09:07:55 EDT
As Petr stated, he hadn't configured the sensors when he tried to start the service. But we agreed that the error message is pretty confusing. The service file needs to be redesigned in order to tell users the real reason why it fails and what to do in order to prevent that from happening.
Comment 5 Jaromír Cápík 2013-07-30 12:46:57 EDT
Ahoj Petře.

Please, test, whether the latest build behaves like expected.
Thanks in advance.

Regards,
Jaromir.
Comment 7 Jaromír Cápík 2013-08-08 15:20:52 EDT
Thanks ... closing.

Note You need to log in before you can comment on or make changes to this bug.