Bug 834230 - [whql][netkvm] Job of "Plug and Play Driver Test (Certification)" stopped for sub job of "Surprise Removal" time out on HCK for winxp / win2k3 / win2k8-32
[whql][netkvm] Job of "Plug and Play Driver Test (Certification)" stopped for...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 05:31 EDT by dawu
Modified: 2013-07-01 00:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 07:12:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
winxp-nic-PlugAndPlayDriverTest(Certification).png (138.43 KB, image/png)
2012-06-21 05:31 EDT, dawu
no flags Details

  None (edit)
Description dawu 2012-06-21 05:31:55 EDT
Created attachment 593398 [details]
winxp-nic-PlugAndPlayDriverTest(Certification).png

Description of problem:
 Job 2059 of "Plug and Play Driver Test (Certification)" stopped for driver surprise Removal time out when run sub job of "StarGroup - DevFundTests.PNPDTest.PNPSurpriseRemoveAndRestartDevice" on HCK for win2k3 and winxp.

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29

How reproducible:
always

Steps to Reproduce:

CLI:

/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=winxp-32-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:45:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:45:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet2,mac=00:10:1a:16:45:03,bus=pci.0,addr=0x6 -uuid 49de09eb-038b-4b05-936a-338fe0c25f66 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winxp-32-nic1,server,nowait -mon chardev=111a,mode=readline -spice port=5931,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio

1. Run job 2059 of "Plug and Play Driver Test (Certification)"

2. Run sub job "Run Test"

3. Auto script will run sub job "StarGroup - DevFundTests.PNPDTest.PNPSurpriseRemoveAndRestartDevice" in guest cmd.
  
Actual results:
driver surprise Removal time out and the whole job stopped going on, there is no any HCK logs,please refer to the attached screen shot "winxp-nic-PlugAndPlayDriverTest(Certification).png" for details

Expected results:
Job should pass without any error.

Additional info:
Comment 2 dawu 2012-06-29 03:03:52 EDT
Hi Yan,

This issue also happened on win2k8-32,but for win2k8-64,it is BSOD with 9F error :
------------------------------------------------------------------------------- 
0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
Arguments:
Arg1: 0000000000000004, The power transition timed out waiting to synchronize with the Pnp
	subsystem.
Arg2: 0000000000000258, Timeout in seconds.
Arg3: fffffa8004f6c720, The thread currently holding on to the Pnp lock.
Arg4: 0000000000000000, nt!TRIAGE_9F_PNP on Win7

Debugging Details:
------------------

Implicit thread is now fffffa80`04f6c720

DRVPOWERSTATE_SUBCODE:  4

IMAGE_NAME:  pci.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  49e024a5

MODULE_NAME: pci

FAULTING_MODULE: fffffa6000bce000 pci

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

STACK_TEXT:  
fffff800`02a9ba28 fffff800`01a47680 : 00000000`0000009f 00000000`00000004 00000000`00000258 fffffa80`04f6c720 : nt!KeBugCheckEx
fffff800`02a9ba30 fffff800`018709fd : 00000000`00000001 00000000`00000000 fffff800`01988cf0 00000000`00000001 : nt!PopBuildDeviceNotifyListWatchdog+0x40
fffff800`02a9ba70 fffff800`0186fe18 : fffff800`02a9bcd0 fffffa60`028fd702 fffff800`02a9bcc8 00000000`00000001 : nt!KiTimerListExpire+0x30d
fffff800`02a9bca0 fffff800`018705af : 000070f9`99781ed4 00000000`00000000 fffff800`00000001 fffff800`0198ba80 : nt!KiTimerExpiration+0x1d8
fffff800`02a9bd10 fffff800`01870ed2 : fffff800`01988680 fffff800`01988680 00000000`00000000 fffff800`0198db80 : nt!KiRetireDpcList+0x1df
fffff800`02a9bd80 fffff800`01a40860 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x62
fffff800`02a9bdb0 00000000`fffff800 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!zzz_AsmCodeRange_End+0x4
fffff800`02a950b0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00680000`00000000 : 0xfffff800


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  X64_0x9F_VRF_4_netkvm_IMAGE_pci.sys

BUCKET_ID:  X64_0x9F_VRF_4_netkvm_IMAGE_pci.sys

Followup: MachineOwner
-------------------------------------------------------------------------------

I'm not sure if there is the same root for BSOD on win2k8-64 and time out issue on win2k8-32,if there is need to separate these two issues, I'll report another one on win2k8-64 for tacking. 

thanks!
Best Regards,
Dawn
Comment 4 Yan Vugenfirer 2012-06-30 15:12:51 EDT
Hi,

Let's leave it as one bug for now.

Best regards,
Yan.
Comment 13 Mike Cao 2012-10-07 21:33:53 EDT
Feedback from MSFT:
This issue appears to be solved after our review of the memory dump we believe this issue is covered under manual errata 1019.
 
Place this number in the read me form.
You can download the form here:
http://download.microsoft.com/download/4/C/3/4C34C72F-FD65-41C9-B89A-A0858A2C3562/windows-hardware-dashboard-submission-readme.docx
 
There are instructions for use of the form within the form.

Since This is manual errata ,QE can not verify it unless we do submissions
Feel free to close this bug .


Mike
Comment 14 Mike Cao 2012-10-09 23:03:36 EDT
note manual errata 1019 expired date is 12/1/2014

Note You need to log in before you can comment on or make changes to this bug.