Bug 834257 - sym comand should print '0x' prefix before printing the actual value
sym comand should print '0x' prefix before printing the actual value
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crash (Show other bugs)
6.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Dave Anderson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 07:20 EDT by Stanislav Kozina
Modified: 2013-03-03 20:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 11:41:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Kozina 2012-06-21 07:20:26 EDT
Description of problem:

sym command should print 0x prefix before the hex address, so the output could be directly passed to px command if neccessary.

Version-Release number of selected component (if applicable):

# rpm -qf /usr/bin/crash
crash-5.1.8-1.el6.x86_64
megatron$ rpm -qf `which crash`
crash-6.0.5-0.x86_64

How reproducible:

Always

Steps to Reproduce:
1. sym schedule
2.
3.
  
Actual results:

crash> sym schedule
ffffffff800623d0 (T) schedule ../debug/kernel-2.6.18/linux-2.6.18-308.el5.x86_64/kernel/sched.c: 3520

Expected results:

crash> sym schedule
0xffffffff800623d0 (T) schedule ../debug/kernel-2.6.18/linux-2.6.18-308.el5.x86_64/kernel/sched.c: 3520

Additional info:
Comment 1 Dave Anderson 2012-06-21 09:17:25 EDT
Sorry, no, that's not going to happen.  A foundational tenet of the
crash utility is the avoidance of the 0x whenever possible, both for user
input and command output.

Now, I would consider adding an option to the "sym" command that would pre-pend
the 0x.
Comment 3 Dave Anderson 2012-06-21 11:12:19 EDT
> Is 123456 Dec/Hex/Oct ?

Can you give me an example where there's a question of what a number is?

> Does crash utility team have any strategy, how to handle such cases?

There's no "crash utility team" -- there's me, plus an active community
that I lead on the crash-utility@redhat.com mailing list.  Patches are
posted there regularly and other discussions held, but I am the gate-keeper
since I wrote the thing from scratch many years ago.  I typically release
a new upstream version once-a-month.  I do have some architecture 
sub-maintainers for ARM, S390X and PPC64, who handle some of the more
machine-specific stuff.
Comment 4 RHEL Product and Program Management 2012-07-10 02:59:47 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 19:10:33 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Note You need to log in before you can comment on or make changes to this bug.