Bug 834341 - webadmin: attach disk does not show the disk description [chrome only]
webadmin: attach disk does not show the disk description [chrome only]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.2.0
Assigned To: Arik
Dafna Ron
virt
: Reopened
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-06-21 11:18 EDT by Dafna Ron
Modified: 2013-06-11 05:37 EDT (History)
10 users (show)

See Also:
Fixed In Version: sf1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-08 11:08:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attach disk - no alias nor description of the disk available (122.86 KB, image/png)
2012-07-05 08:55 EDT, Yaniv Kaul
no flags Details

  None (edit)
Description Dafna Ron 2012-06-21 11:18:56 EDT
Description of problem:

attach disk does not show the description field. 
since we cannot attach a disk from the disks tab and we can have same disks with the same name I think it would be a good idea to add the description field to the attach dialogue. 

Version-Release number of selected component (if applicable):

si6

How reproducible:

100%

Steps to Reproduce:
1. create floating disks+direct lun disks
2. attach to vm
3.
  
Actual results:

we have no description in the attach disk dialogue. 

Expected results:

we should add this column. 

Additional info:
Comment 1 Tal Nisan 2012-06-28 11:10:33 EDT
http://gerrit.ovirt.org/#/c/5780/
Comment 2 Yaniv Kaul 2012-07-05 08:54:23 EDT
SI9.1:
No change in behavior - In the Attach Disk dialog I cannot see neither the disk Alias nor the disk Description.

BTW, why are we calling it disk alias and not disk name?
Comment 3 Yaniv Kaul 2012-07-05 08:55:10 EDT
Created attachment 596406 [details]
attach disk - no alias nor description of the disk available
Comment 4 Tal Nisan 2012-07-08 10:39:09 EDT
Just checked it on si9.1, works for me, can you please check it on Firefox, maybe that's the problem
Comment 5 Yaniv Kaul 2012-07-08 11:08:15 EDT
(In reply to comment #4)
> Just checked it on si9.1, works for me, can you please check it on Firefox,
> maybe that's the problem

Correct. 
Does not work: Chrome v20.0.1132.47 (Official Build 144678) beta
Works: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Comment 6 Michal Skrivanek 2012-07-17 04:59:46 EDT
Well, the dialog is missing the width parameters for most of the columns, so they are considered 0. Firefox somehow makes up his own number. This seems to be wrong in VmDiskPopupWidget.java, I guess the width should be defined for all columns.
Comment 9 Arik 2012-10-28 10:40:47 EDT
http://gerrit.ovirt.org/8866
Comment 10 Arik 2012-11-04 07:52:16 EST
This bug was merged upstream
Comment 13 Dafna Ron 2012-12-27 08:07:04 EST
verified on sf2 on firefox and chrome.
Comment 14 Itamar Heim 2013-06-11 05:09:35 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 05:09:39 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 05:37:44 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.