This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 834347 - gnome-terminal through ssh session fails because of stale X server property
gnome-terminal through ssh session fails because of stale X server property
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 11:26 EDT by Eric Hopper
Modified: 2013-08-01 00:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 00:07:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Hopper 2012-06-21 11:26:50 EDT
Description of problem:
Running gnome-terminal through ssh causes gnome-terminal to exit immediately.

Version-Release number of selected component (if applicable):
gnome-terminal-3.4.1.1-1.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. ssh -Yf foohost gnome-terminal
  
Actual results:
Exits and no window ever appears

Expected results:
A gnome-terminal window showing up on my X display.

Additional info:
So, I figured out what the actual problem is. A stale property on my X server.

Basically, I updated the software on foohost, and then rebooted it. After the reboot gnome-terminal would refuse to start. If I logged in with 'ssh -Y foohost' and ran 'gnome-terminal' it would simply exit silently. If I did 'gnome-terminal --disable-factory' I got this message:

$ gnome-terminal --disable-factory

(gnome-terminal:2941): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Failed to connect to socket /tmp/dbus-griNv12JwP: Connection refused
Failed to summon the GConf demon; exiting.  No D-BUS daemon running

I logged into the console X session on foohost and started a gnome-terminal there and it worked just fine. I then copied out the DBUS_SESSION_BUS_ADDRESS environment variable and set the same value in the ssh session. gnome-terminal again began to work.

I started filling out this bug report.

Then I had an epiphany and exited the X server (it's on an OS X laptop) and tried 'ssh -Yf foohost gnome-terminal' again. The X server auto-started like it's supposed to and a gnome-terminal window magically appeared.

From this I conclude that gnome-terminal was trying to get the DBUS session information from a property on the X server, but that information was stale.

This behavior is still sub-optimal, and it should be fixed. If that information appears to be invalid for whatever reason, a new dbus session should be created or some other similar measure.
Comment 1 Alan Hamilton 2013-06-21 23:49:26 EDT
Although I haven't been able to reproduce the issue reliably, this seems to resolve it when it occurs. 

dbus-launch --exit-with-session gnome-terminal

This starts a new DBUS environment for gnome-terminal.
Comment 2 Fedora End Of Life 2013-07-03 20:25:37 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2013-08-01 00:07:29 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.